7

Previous the upgrade, my bashrc file was modified in order to add some Path configuration.

While executing do-release-upgrade everything was fine until a message prompted about the status of the bashrc file and an option menu was displayed.

From the menu, I chose the "compare changes" option and the only difference was my previous modification. No problem.

Here is the problem: I ctrl-c and the whole upgrading stopped. After that, I rebooted my computer and from then it is possible to start Ubuntu only in recovery mode.

After logging in (in recovery mode shell) the welcome header message says "Welcome to Ubuntu 15.04" but the "your Ubuntu release is not supported any more" and "new release '15.04' available" warnings still appear.

I've tried to do-release-upgrade again but got the "no new release found" message.

How can I finish or re-run the upgrade??

Thanks

2

You have already partially installed 15.04. There is no point in doing a do-release-upgrade any-more, and it will naturally say "No new release found".

What you need to do it is the below command which will install the missing packages, assuming apt-get is installed in the first place:

sudo apt-get update && sudo apt-get dist-upgrade
| improve this answer | |
  • Thanks @daltonfury42, I'm gonna check this because it's the strict answer to my problem. The answer that I posted includes links for further problems that may or may not happen at all. – E_d Aug 8 '15 at 7:03
  • 1
    E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) – Cerin Mar 21 '17 at 16:57
  • I have the same problem as @Cerin in that the terminal was closed and now there is a lock that I don't know how to release. – BadHorsie May 31 '17 at 14:17
  • 1
    @BadHorsie, I had to delete the lock file and then run sudo dpkg --configure -a. This question is essentially a duplicate of this one. – Cerin May 31 '17 at 18:48
4

This worked for me (running this after a reboot) it started off where the upgrade was interrupted.

sudo dpkg --configure -a
| improve this answer | |
0

Finally, it's solved. For those who have same or similar problem:

In the recovery mode shell: sudo apt-get update && sudo apt-get dist-upgrade

It took a couple of minutes and after reboot "starting version 219" message appeared. So I followed this link:

You may get such an error if your display manager is not sddm. Running the following can show which display manager you are using : cat /etc/X11/default-display-manager

For example, if your display manager is /usr/sbin/gdm, running the following may help : sudo systemctl enable gdm.service -f

After rebooting, I got "Failed to start user service user@1000.service", then followed this thread:

sudo apt-get purge fglrx*

sudo update-alternatives --remove-all x86_64-linux-gnu_gl_conf

sudo apt-get install --reinstall libgl1-mesa-dri libgl1-mesa-glx

sudo apt-get install fglrx-updates*

And now everything is fine.

| improve this answer | |
  • 1
    Can you please buff up your answer and add the procedere used here, links can change as well as the content you're linking to so your answer can become a dead end. – Videonauth May 6 '16 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.