when I launch skype from the launcher, it flashes then nothing happens. If I run it from command line it works. From command line I get these warnings however:

skype:2018): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(skype:2018): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(skype:2018): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(skype:2018): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

Anybody has the same issue and knows how to work around it?


  • Those warnings show up with almost every app in Ubuntu 11.10 – RobinJ Oct 23 '11 at 15:53

Try this: sudo aptitude install gtk2-engines-pixbuf

That worked for me in a similar problem...


Have you tried perhaps editing your menu entry for Skype. I had to in previous releases just to get my webcam functioning with Skye.

I had to reinstall Main Menu from the Software Centre then look under Internet>Skype and insert the following in properties as in this guide Ubuntu Skype Fix

Please note as you are using 11.10 you will insert

bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'

into the command box

Let us know if that works


I had the same problem in 11.10 and fixed it by going to the Dash Home, clicking on Internet Applications → Installed → See more more results → Skype.

After invoking Skype from there, it appeared in the side bar, and once there, I clicked Keep on launcher. At this point I had 2 Skype icons on the side panel: the one from the installation, which did not work, and the one just invoked, which now works. I deleted the first one, and presto.

I did not install any extra packages.

Hope this helps as well.


I followed instructions here to get Skype working on Oneiric 64bit.

First run:

echo foreign-architecture i386 | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch 

Then see if some packages are missing:

sudo apt-get install libxss1:i386 libqtcore4:i386 libqt4-dbus:i386 libasound2:i386 libxv1:i386 libsm6:i386 libxi6:i386 libXrender1:i386 libxrandr2:i386 libfreetype6:i386 libfontconfig1:i386

I just installed Skype from the software center, and told software center to add it to my launcher. When starting skype from the launcher, nothing happened. It worked when I started it from the Dash. I removed Skype from the Launcher and dragged it from the Dash to the Launcher to put it in the Launcher again. When I clicked the newly created shortcut in my Launcher, it worked. Seems that the software center does something wrong when creating the shortcut in the Launcher.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.