6

Asking, because it took a minute to figure this out and nothing came up on Google. Answer coming up.

I downloaded a Firefox (nightly) build from mozilla.org for testing. Running it presented an error:

$ firefox
XPCOMGlueLoad error for file /home/parallels/firefox-32/libmozgtk.so:
libgtk-3.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

The file does exist on my Ubuntu 14.04 LTS:

$ locate libgtk-3.so.0
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0
/usr/lib/x86_64-linux-gnu/libgtk-3.so.0.1000.8
6

Turns out I needed to download the x86_64 version from the Mozilla site, not the 32-bit version.

| improve this answer | |
  • 1
    Thanks for saving my time. I had the same problem when downgrade from firefox version 48 to 47 in ubuntu 14.04. – zhihong Aug 18 '16 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.