8

I have installed Ubuntu 15.04 on my new Intel NUC

However the wifi does not work.

It complains (in dmesg) that the iwlwifi module was unable to load the firmware code because iwlwifi-3165-10.ucode could not be found.

I've tried installing newer versions of iwlwifi (from backports), but that seemed very complicated and didn't seem to help.

  • I had this same issue with Ubuntu 16.04 and 16.10, which both have a newer kernel than 4.1. There these commands helped me: sudo modprobe -r acer-wmi; sudo rfkill unblock all. After confirming, the following command makes it permanent: echo "blacklist acer-wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf – Unksi Dec 7 '16 at 7:04
8

I had this same problem but figured it out. The best way to see if this was your issue is to run this script:

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info
chmod +x wireless-info
./wireless-info

You'll find the output in the /root directory. Toward the bottom of the output, you may see some dmesg errors that say that it has attempted to load the right iwlwifi drivers but ultimately says "no suitable firmware found!"

To fix this problem:

  1. Check the Linux kernel you are using

    uname -r
    

    Even if you've installed Ubuntu 15.04, it's still using the 3.19 Kernel.

  2. Right now, Intel is only supporting the 3165 hardware with firmware for 4.1+, but I couldn't get it to work until I upgraded to 4.2. It's easiest by using wget to get the right version for your hardware, and for whatever kernel you want to use. I used the most recent version on kernel.org. Use wget to get them:

    wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2-rc8-unstable/linux-image-4.2.0-040200rc8-generic_4.2.0-040200rc8.201508240030_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2-rc8-unstable/linux-headers-4.2.0-040200rc8_4.2.0-040200rc8.201508240030_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.2-rc8-unstable/linux-headers-4.2.0-040200rc8-generic_4.2.0-040200rc8.201508240030_amd64.deb
    

    And then issue the following command:

    sudo dpkg -i *.deb
    

    Reboot and you should now see the correct kernel:

    sudo uname -r
    

    Update and upgrade, and you're all set:

    sudo apt-get update
    sudo apt-get upgrade
    

    Suddenly, wireless. And this time, you can actually connect to it. :D

    Some last minute clean up, regenerating the grub menu and removing the previous kernel:

    sudo update-grub
    sudo apt-get autoremove
    

BAM! You're done.

  • Instead of wget, run: sudo modprobe iwlwifi, then: dmesg | grep iwlv. this will display the "no suitable firmware found!" message in your terminal – user697576 Nov 15 '15 at 16:57
  • dude, you rock man.. worked like a charm.. – Siddharth May 2 '16 at 18:15
0

I solved it by upgrading the linux kernel to 4.1.

I used this guide: http://ubuntuhandbook.org/index.php/2015/06/upgrade-kernel-4-1-ubuntu-linux-mint/

Not the answer you're looking for? Browse other questions tagged or ask your own question.