0

For some reason I have the proxy set:

$ echo $http_proxy
http://123.456.11.11:80/

But I can't find where it is, ~/.bashrc, ~/.profile and /etc/bashrc don't contain it. And in System->Setting it's not set either. So how do I find out where it is?

1

It is set in /etc/environment.This sets the variable for every user,system wide

4
  • I removed it but after reboot http_proxy is set again. /etc/env-t doesn't hold it. – Oskar K. Aug 9 '15 at 10:31
  • Go to System Settings->Network.Change Network Proxy's method(in drop down) to None,and apply changes system wide.Restart,and it should work.If it doesn't try env | grep http_proxy in terminal and see where it is set – user3615045 Aug 10 '15 at 6:24
  • of course, it's None. – Oskar K. Aug 10 '15 at 15:18
  • check in /etc/wgetrc and /etc/apt/apt.conf.d/ .These are the possible locations where system wide settings can be found,other than /etc/environment – user3615045 Aug 11 '15 at 4:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.