1

I have 3 screens currently active, running through one of my ASUS R9 270X graphics cards, (I did have 2 in but I was getting problems with the display and the ASUS/AMD proprietary drivers crashed my system.) I now have Ubuntu Mate 15.05 running through a single 270x, which is working fine (It crashes when I try to use 4 for some reason - the screen goes all mosaic on me). The problem that I am having now, is Icons are missing from my display, but show up on where the 4th monitor should be on a black background, when I do CTR-ALT-Arrow Key. Plus also parts of one of my active screen is dead. I can have a window open on it, and only half or the window responds (the right side). I dont know what is causing this, does any one have any clues?

xrandr output:

warren@RIVE:~$ xrandr
Screen 0: minimum 320 x 200, current 3360 x 1950, maximum 16384 x 16384
DisplayPort-0 connected 1680x1050+0+900 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1680x1050+1680+900 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
DVI-1 connected 1440x900+1920+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900       59.9*+   75.0  
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
  • I'm using the 'AMD, Inc [AMD/ATI]:curacao XT [Radeon R9 270X], on the option. *Using X.Org X server - AMD/ATI Display driver wrapper from xserver-xorg-video-ati (open source, tested) – user66260 Aug 7 '15 at 14:09
  • I cant see an xorg.conf file in /ect/x11 just an Xwrapper.config – user66260 Aug 7 '15 at 14:13
0

Have you described your devices / monitors configuration in /etc/X11/xorg.conf ?

If not, I would advice you to do so, it was the only way to get my 3 monitors working on Ubuntu 15.04.

You can look at my question to see some examples of configuration files, and ways to manage displays through xrandr or xorg.conf.

Additionnaly, if you want more precise help :

  • which drivers are you using ? Open source (radeon) or proprietary (fglrx) ?
  • what's the result of xrandr ?
  • what's the result of lspci | grep VGA ?
  • How are your monitors arranged on you desk ? Describe the position / rotation depending on which connector they use : DisplayPort / DVI-0 / DVI-1.

To know which display is on DVI-O or DVI-1, just run:

xrandr --display DVI-0 --off

it will disable the display on DVI-0.

To reenable it :

xrandr --display DVI-0 --auto

Here is a first attempt with all displays in landscape in the order from left to right (DP / DVI-0/ DVI-1), be aware that you need to edit the line BusID with the correct PCI address given by the command lspci | grep VGA.

Put these lines in /etc/X11/xorg.conf :

Section "ServerLayout"

    Identifier     "home_config"
    Screen      0  "Screen-DisplayPort-0" 0 0
    Screen      1  "Screen-DVI-0" 1680 0
    Screen      2  "Screen-DVI-1" 3360 0

EndSection

Section "Files"

    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "built-ins"

EndSection

Section "Module"

    Load  "extmod"
    Load  "dri"
    Load  "dri2"
    Load  "dri3"
    Load  "dbe"
    Load  "glx"
    Load  "record"

EndSection

Section "Device"

    Identifier  "R9270X"
    Driver      "radeon"
    BusID       "PCI:4:0:0" #<--- replace here with the PCI adress given by lspci | grep VGA
    Option      "Monitor-DVI-0" "Display-DVI-0"
    Option      "Monitor-DVI-1"  "Display-DVI-1"
    Option      "Monitor-DisplayPort-0" "Display-DisplayPort-0"
    Option     "AccelMethod" "glamor"
    Option      "ModeDebug" "true"

EndSection

Section "Monitor"

    Identifier "Display-DisplayPort-0"
    Option "PreferredMode"  "1680x1050"
    Option "Position" "0 0"
    Option "Enable"  "true"

EndSection

Section "Monitor"

    Identifier "Display-DVI-0"
    Option "PreferredMode"  "1680x1050"
    Option "Position" "1680 0"
    Option "Enable"  "true"
    Option "Primary" "true"

EndSection

Section "Monitor"

        Identifier "Display-DVI-1"
        Option "PreferredMode"  "1440x900"
        Option "Position" "3360 0"
        Option "Enable"  "true"
EndSection


Section "Screen"

    Identifier "Screen-DisplayPort-0"
    Monitor "Display-DisplayPort-0"
    Device "R9270X"
    DefaultDepth    24
    SubSection     "Display"
        Viewport 0 0
        Depth 24
    EndSubSection
EndSection

Section "Screen"

    Identifier "Screen-DVI-0"
    Monitor "Display-DVI-0"
    Device "R9270X"
    DefaultDepth    24
    SubSection     "Display"
        Viewport 0 0
        Depth       24
    EndSubSection

EndSection

Section "Screen"

    Identifier "Screen-DVI-1"
    Monitor "Display-DVI-1"
    Device "R9270X"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
            Viewport 0 0
    EndSubSection

EndSection

Section "DRI"
    Mode 0666
EndSection

If something goes wrong and you can't access your display manager:

  1. reboot in recovery mode
  2. rename the file xorg.conf : sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
  3. reboot : sudo reboot (or restart your display manager sudo service lightdm restart for example)
  4. provide error logs : cat /var/log/Xorg.0.log | pastebinit and cat /var/log/Xorg.1.log | pastebinit

Good luck !

  • Please see above. and thanks for your help it is appreciated. – user66260 Aug 7 '15 at 14:24
  • just added two others questions to help me give you an appropriate xorg.conf file – aklmie Aug 7 '15 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.