0

When i just try adjusting brightness, the indicator changes but the screen does not change brightness. I have tried adding acpi_backlight=vendor to my grub file and also doing

echo x > sudo tee /sys/class/backlight/dell_backlight/brightness

and

echo x > sudo tee /sys/class/backlight/intel_backlight/brightness

Brightness used to change fine but now is not working on a new ubuntu install. I am using a dell xps 14 with a NVIDIA 630M using the nvidia-340-updates driver & nvidia prime. Also supports ivybridge graphics but I am using the 630m. Thanks in advance

EDIT:
creating /X11/xorg.conf.d/20-intel.conf did not fix my issue.
Model is Dell XPS 14-l421x
kernal version 3.16.0-45-generic
Updating to kernal 3.19.0-25-generic and ubuntu 15.04 did not fix my issues
The problem was the bios setting "Load legacy option rom" being set to Enabled, setting this to disabled fixed my backlight.

1
  • What is your laptop model?
    – Pilot6
    Aug 7, 2015 at 12:44

2 Answers 2

0

i can recommend you to upgrade to newer kernel, or you can try to create file /usr/share/X11/xorg.conf.d/20-intel.conf with this code in it:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection
5
  • creating the file did not change anything.
    – Noctane
    Aug 7, 2015 at 12:44
  • you should create it with root permissions and you must reboot your PC after that. Anyway that worked for me on my Acer laptop which was with i believe 3.12 kernel, but after i updated kernel to newer version issue gone completely. What kernel ver. do you use? Type uname -r in terminal and post output. Aug 7, 2015 at 15:23
  • I tried again and still nothing, file was definitely created as root. my kernal is version 3.16.0-45-generic
    – Noctane
    Aug 8, 2015 at 3:37
  • As i said before, i can only recommend you to install newer kernel. Because 20-intel.conf and acpi_backlight=vendor solutions don't work for you, which is strange. Aug 8, 2015 at 10:44
  • Updating to 3.19.0-25-generic as well as ubuntu 15.04 did not fix my issue. turned out to be a BIOS settings problem.
    – Noctane
    Aug 14, 2015 at 4:02
0

I Fixed my problem. The solution for me was enabling "Load legacy option rom" in the BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.