2

I need to show my desktop in gray-scale mode. On MacOS I can do it in accessibility mode. I tried with compiz config but the color filter was removed from Ubuntu 14.04.

Who can help me?

I use Ubuntu 14.04 with Unity.

  • Sorry not a duplicate. I misread your question. – hg8 Aug 7 '15 at 9:33
  • could you repair ? – Nicola Milani Aug 7 '15 at 11:00
4

You can use the Opacity, Brightness & Saturation plug-in.

  1. Open ccsm Compiz manager
  2. Go to Accessibility → Then enable: Opacity, Brightness & Saturation
  3. Open it, Go to Saturation tab
  4. Add new rule:

    Windows: any Value: 0

I got all windows in grayscale only unity dash & top panel still in color, may be needs a reboot. :) sorry not the time to test that.

enter image description here

BTW, it is possible to get a hardware solution for VGA with just few resistors to make an RGB channels merger/mixer.

| improve this answer | |
  • 2
    Note that you might have to install "compiz-plugins" (sudo apt-get install compiz-plugins) to have this option in ccsm. – Marc Apr 20 '18 at 9:06
2

I think you can achieve what you want with xcalib If it's not installed:

 sudo apt-get install xcalib

try something like

 xcalib -i -a

 xcalib -invert -alter

 xcalib -co 70 -a

To reset screen

 xcalib -c

For more info about xcalib check out http://manpages.ubuntu.com/manpages/precise/man1/xcalib.1.html

or

xcalib -h

Following link may also help out How can Ubuntu be made grayscale?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.