5

I tried sudo apt-get install xubuntu-desktop. It turned out like this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xubuntu-desktop : Depends: gtk2-engines-pixbuf but it is not going to be installed
                   Recommends: abiword but it is not going to be installed
                   Recommends: abiword-plugin-grammar but it is not going to be installed
                   Recommends: abiword-plugin-mathview but it is not going to be installed
                   Recommends: brltty-x11 but it is not going to be installed
                   Recommends: gimp but it is not going to be installed
                   Recommends: gthumb but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Anyone knows what this means and how to fix it ?

  • PS: If I have installed Xubuntu-desktop, how can I remove the Unity?
  • Thank you.

`

0
2

Seems like you had a broken update or software install so either your apt-cache is messed up or your dpkg isn't getting a lock. First try

sudo dpkg --configure -a

Then:

sudo apt-get update
sudo apt-get autoclean
sudo apt-get clean
sudo apt-get autoremove
sudo dpkg --remove -force --force-remove-reinstreq broken-packagename

Optionally to remove unity:

sudo apt-get purge ubuntu-default-settings

sudo apt-get purge ubuntu-desktop

sudo apt-get autoremove
1

You should something like this:

sudo apt install xubuntu-desktop <and its dependencies separated by space>

In your error it should be like:

sudo apt install xubuntu-desktop gtk2-engines-pixbuf abiword abiword-plugin-grammar abiword-plugin-mathview brltty-x11 gimp gthumb
-1

Have you tried installing the base xfce desktop package called "xfce4"? Installing that will install the base xfce desktop, without all of the extra packages used by Xubuntu (eg, gnome-dependencies, xubuntu artwork, etc). This way you wouldn't have more than one text editor, update manager, cd burner, audio player, etc (because thay are all required by Xubuntu).

After installing XUbuntu , you can remove Unity by

sudo apt-get autoremove --purge unity unity-common unity-services unity-lens-\* unity-scope-\* unity-webapps-\* gnome-control-center-unity hud libunity-core-6\* libunity-misc4 libunity-webapps\* appmenu-gtk appmenu-gtk3 appmenu-qt\* overlay-scrollbar\* activity-log-manager-control-center firefox-globalmenu thunderbird-globalmenu libufe-xidgetter0 xul-ext-unity xul-ext-webaccounts webaccounts-extension-common xul-ext-websites-integration gnome-control-center gnome-session

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.