I am currently running a dual boot of Windows 10 Home 64-bit and Xubuntu 15.04 64-bit on my machine. I have Windows 10 on an SSD, Xubuntu on another SSD and an HDD for storage formatted as NTFS (this is used to store music, games, documents, pictures etc.). The GRUB2 boot-loader is also on the SSD with Xubuntu. Previously I used this exact set-up with Windows 7 instead of 10 and there were no issues with booting into my desired OS via GRUB2, as well as being able to mount the NTFS storage drive in Linux.

Here is the problem I am experiencing now:

After about 10 or so boots into Linux, I turn on my computer and the boot order has changed and it wants to boot straight to Windows 10. After changing the boot order back, my NTFS drive will not mount due to the error described, and resolved here:

Can't Mount NTFS drive "The disk contains an unclean file system"

(I can use the fix provided in the link, but this is a major annoyance as there are dependencies between my Linux OS and the NTFS drive.)

My boot device order is USB, Hard-disk, CD-ROM (all non UEFI) followed by others including the UEFI options. For the Hardisk order I want to have Linux, Windows, Storage... but when the boot order gets reset I get Windows, Storage, Linux.

I have a hunch it has something to do with "Secure Boot" and Windows 10, where Windows 10 prevents other bootloaders from functioning. I skipped Windows 8 so I am not familiar with this feature, and after some research I am a bit confused about Secure Boot and how to deal with it.

So my question is: How can I prevent Windows 10 from changing my boot order and messing with the mounting of the NTFS storage drive?

Some other pertinent information:

System Specs



MSI Z77A-G45 (I updated the bios to the 2013-09-29 version found here: http://ca.msi.com/support/mb/Z77AG45.html/#down-bios)

Kingston 128GB SSD - Linux

Adata 128GB SSD - Windows 10

WD 2TB Black - Storage

BIOS INFO After the update in the advanced settings menu there is a Windows 8 features menu. If I enable Windows 8 features I can then choose to enable or disable secure boot, but when enabling Windows 8 features I am forced to boot with UEFI devices and my computer cannot boot. So I have the Windows 8 features toggle set to disabled right now.

  • Are you saying your default grub entry has changed to windows instead of Linux which is what you want to be default? – FreeSoftwareServers Aug 6 '15 at 23:23
  • With UEFI, operating systems can change some settings. But with BIOS it cannot. Not sure if UEFI in BIOS mode can have settings changed or not. Normally with BIOS you set drive boot order and that is fixed. If both systems are set for CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode then you cannot turn on secure boot as that is UEFI boot only. – oldfred Aug 6 '15 at 23:53
  • @FreeSoftwareServers No, my boot order in the BIOS is changing so that the GRUB bootloader is not on the default one chose. – jasper Aug 7 '15 at 2:58
  • Also, someone on Super User mentioned Fast Boot, which I have turned on, may be causing the problem. I am going to try turning it off. – jasper Aug 7 '15 at 3:00
  • *windows fastboot* – jasper Aug 7 '15 at 3:28

The reason for my problems was that Windows Fast Boot was turned ON. I turned it off by going to Control Panel->Hardware and Sound->Power Options->System Settings and deselecting Turn on fast startup under Shutdown Settings. Grub has been loading flawlessly for the past five days and their have been no conflicts between Windows and Linux.

| improve this answer | |
  • I have a similar case, Windows 10 (most recent update) and Ubuntu 17.04. Each on a different SSD drive, and a 3rd hard drive (not SSD). I just turned off the windows fast boot and I still get GRUB replaced in the BIOS by Windows Boot Manager. Any idea? – xarlymg89 Oct 25 '17 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.