3

I installed Ubuntu 15.04 and I have problems with my 2 monitors.

I need to set my left monitor as primary before the login screen appears, because the login screen appears on right monitor. I found some solutions. But:

  • ati drivers are not supported by 15.04.
  • xprofile isn't working.
  • script with lightdm.conf not working.
  • xorg.conf was missing.

I generated it, but it generated this

    Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>:   "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                 # [<bool>]
        #Option     "SWcursor"              # [<bool>]
        #Option     "EnablePageFlip"        # [<bool>]
        #Option     "ColorTiling"           # [<bool>]
        #Option     "ColorTiling2D"         # [<bool>]
        #Option     "RenderAccel"           # [<bool>]
        #Option     "SubPixelOrder"         # [<str>]
        #Option     "AccelMethod"           # <str>
        #Option     "EXAVSync"              # [<bool>]
        #Option     "EXAPixmaps"            # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "EnablePageFlip"        # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
    Identifier  "Card0"
    Driver      "radeon"
    BusID       "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

It looks like it isn't complete config, I see there only one monitor, no resolution settings etc.

How can I edit it?

My xrandr output:

Screen 0: minimum 320 x 200, current 3040 x 900, maximum 8192 x 8192
DisplayPort-0 connected 1440x900+1600+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900       60.0*+   75.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1280x800       59.8  
   1152x864       75.0  
   1152x720       60.0  
   1024x768       75.1     60.0  
   832x624        74.6  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
DVI-0 connected primary 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 256mm
   1440x900       59.6*+   75.0  
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1 

Also I need to set xrandr brightness to 0.8 for one monitor permanently. It is old and there is some hardware problem and screen is so white.

When I set brightness through terminal, it looks better, but after restart it goes back do default. Sometimes it just resets while working too.

0

Browse other questions tagged or ask your own question.