I just installed Ubuntu 11.10 (64 bit) and my touchpad is dead. Some ideas?


8 Answers 8


Because it is not working only in Gnome 3 and Unity 3D, you can fix it like this :

  • Install dconf-tools Install dconf-tools
  • Launch it dconf-editor
  • Search for: /org/gnome/settings-daemon/peripherals/touchpad/
  • Check "touchpad-enabled"
  • Worked perfectly, and doesn't even require a reboot. This should be the accepted answer, for my problem at least. Thanks. Mar 27, 2012 at 18:41

Here is the trick :

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps
  • Actually after a restart it is not working again. Even more, the configuration of the touchpad is not working anymore with this fix.
    – Natim
    Oct 14, 2011 at 14:25
  • messing with kernel modules should not be necessary, especially if the touchpad started out working. Oct 22, 2011 at 17:48
  • This works on my Ubuntu 11.10 install (network upgrade from Natty). However on the next boot the touchpad goes back to dead. How can this be made permanent? Is it safe to place it on rc.local?
    – Marky
    Jan 31, 2012 at 10:46
  • You should use askubuntu.com/a/66197/11333
    – Natim
    Feb 2, 2012 at 12:55

This worked for me:

System Settings > Mouse and Touchpad > Touchpad

in section General uncheck 'Disable touchpad while typing'. Restart.

  • 1
    this worked for me as well. It seems like it's disabling the touchpad when typing starts, then just never re-enables it. Oct 22, 2011 at 17:47

I had the same issue right after upgrading to 11.10 on my Dell Inspiron. What I did was install Synaptiks touchpad management from the Ubuntu Software center, logged out, then logged back in. Now my touchpad is working well.

  • It didn't worked for me. But then strange thing is that the touchpad is working on the login screen, detected by all the pointing configuration systems but not working under Unity.
    – Natim
    Oct 14, 2011 at 13:10
  • Touch the enable/disable function key for the touchpad at login
    – P05TMAN
    Oct 15, 2011 at 0:58


Comment #32 contains a fix for Elantech touchpads. Check if your dell has one.


It appears something political happened, but either way the touchpads have technically changed brand.

To fix:

  1. edit the file /etc/acpi/asus-touchpad.sh (you'll probably need sudo)
  2. change the following line:
XINPUTNUM=`xinput list | grep 'SynPS/2 Synaptics TouchPad' | sed -n -e's/.*id=\([0-9]\+\).*/\1/p'`


XINPUTNUM=`xinput list | grep 'ETPS/2 Elantech Touchpad' | sed -n -e's/.*id=\([0-9]\+\).*/\1/p'`

Source: This question was posed here on launchpad.net, and the solution is on this post.


I had the same problem on an XPS17 L702x. Its pretty simple to fix, just disable the flag to 'Disable touchpad while typing'. There are more tunable things you may be interested in to get your XPS all working sweetly. All the information is here...



I found this link with a solution for the same problem when I was troubleshooting another synaptics touchpad problem:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .