I installed Ubuntu 10.10 and have updated to 11.04 and now 11.10.

I switched from using Ubuntu Classic / GNOME Classic to Unity for this release. The problem is, the super key menu (Dash), doesn't seem to search applications.

I'm trying to look for Google Chrome and no matter what I search, it only searches for files. It doesn't seem to matter what lens I use either, such as by clicking "Internet Apps" or "Media Apps".

What can I do to fix this?

EDIT: Ubuntu Software Centre seems to fail when I search for any application as well!


I was having issues with Dash too after a failed upgrade from 11.04 -> 11.10. To finally fix it I had to do:

sudo apt-get install unity-lens-files unity-lens-music unity-lens-applications

Afterwards, dash started behaving correctly again. I guess the install missed those at some point.


I don't have an answer but I am experiencing the same problem. I found and tried a solution for this problem in 11.04 on here, which was reinstalling the application lens, but it made no difference.

My application lens doesn't appear in the dash, just home, documents and music, so the dash doesn't search any applications, clicking on 'more apps' doesn't bring anything up.

I had this problem in 11.10 beta 2 so I went back to 11.04, which worked fine, until release. I have my home folder on a separate partition to the OS. I did a clean install today, mounting my home folder partition, and the application lens still hasn't appeared.

Makes me think the problem must be somewhere in a config file or something saved in my home folder since the 11.10 beta 2.

Has anyone got any ideas what might be causing this?

EDIT: I also can't work out how to reply to the original question with anything but an answer, apologies.

  • I still have an "application.lens" file under "/usr/share/unity/lenses/applications/", and there doesn't seem to be any problem using the other .lens files (files.lens and music.lens). However it seems like the commands.lens isn't working either. I can't run any command using "alt + F2". Also, like the original poster software center crashes on launch. After two attempted and failed launches it doesn't open at all, the icon just pulses then nothing.
    – Mike
    Oct 13 '11 at 18:20
  • 1
    The application lens appears and works normally under the guest account on the same install of Ubuntu, so the problem must be to do with some option stored under the home folder of the user.
    – Mike
    Oct 13 '11 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.