1

I have a lenovo thinkpad with a firewire express adaptor card that I recently setup for recording. I connect my maudio controller either/and via 5 din midi to my audio interface or via usb to my laptop. At the moment I need to be able to connect via usb midi.

I am using Ubuntu Studio 14.01 LTS with KXstudio repositories. ( I am not writing from my laptop at the moment so I can't recall the exact kernel at the moment), I am getting messages that are close to :

....usb-2/1 device not accepting address 4, error -110 usb 1.0 unable to enumerate usb devices....

I will have to access the logs to get the exact boot errors.

My maudio controller has mostly worked fine and when the usb midi was not recognised I rebooted and switched to a powered usb slot and then it worked. Now it will not be recognised no matter what usb port or whether I still power it with an AC adaptor as well. I even got a single AB usb 2.0 cable thinking it was having a hard time recognising my usb extension cable. I never have had any issues with usb midi on my desktop and Ubuntu Studio.

I was wondering if any ever had such issues and how did they resolve it??

closed as off-topic by guntbert, Melebius, Volker Siegel, Charles Green, David Foerster Sep 5 '18 at 16:52

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – guntbert, Melebius, Volker Siegel, Charles Green, David Foerster
If this question can be reworded to fit the rules in the help center, please edit the question.

  • It is not entirely clear which combinations of port/cable/device you have tested, but if I understand your description correctly, it points to a hardware defect in your USB/MIDI interface. – CL. Aug 6 '15 at 8:37
  • 2
    Voting to close this question: OP stated it was a problem of a too long USB-cable. – guntbert Sep 3 '18 at 18:53
1

CL, indeed it was a hardware issue or more specifically, I found out that my laptop usb ports seem to not handle a cable of more than 12 feet! I still have to power the controller with a separate adaptor as well. I have only had experience with desktops and longer usb cables still worked fine and powered the controller as well.

So for now I am managing with a shorter cable then ideal but I will need to get a powered usb hub if I want to use a 15 foot cable.

Not the answer you're looking for? Browse other questions tagged or ask your own question.