0

I have the HP LaserJet Pro MFP M125nw all-in-one printer-scanner. In Ubuntu 14.10 I had it up and running using the hplip 3.15.7 (the latest from hplipopensource.com, not the repositories).

After upgrading Ubuntu to 15.04 the printing stopped working. I tried to remove and setup the printer again, no luck. I tried to remove hplip and install it again, no luck. Running hp-check gives no error whatsoever. What happens when I print something (e.g. test page from hp device manager) is following:

  • I issue printing (clicking print somewhere)
  • Printing ...
  • Started a job ...
  • Job completed ...
  • Printing stopped ...

all combined taking about 10 seconds. And when I look at job queue in the device manager there is one job with status "Stopped".

I am in the lp group.

Scanning works fine.

I really don't know where the problem could be because I think I checked everything (but apparently not). I need your help.

  • I'm having the same problems with a Color LaseJet MFP M277dw! – aba Sep 24 '15 at 9:27
0

I issued a bug on launchpad and received a comment there:

This is an issue with hplip 3.15.7 drivers. I have provided the patch for the same in the bug report https://bugs.launchpad.net/hplip/+bug/1476920. This issue will be resolved in our next version of hplip.

If you wish to go back to hplip-3.15.6. You can download the drivers from http://sourceforge.net/projects/hplip/files/hplip/3.15.6/hplip-3.15.6.run/download

Sorry for the inconvenience.

So it is the bug in hplip 3.15.7. Using the older 3.15.6 solves this problem. I recently upgraded to 3.15.9 and it works as well.

  • I have lplip Version: 3.14.3-0ubuntu3.4, but have similar with my HP Laserjet printer. – PHP Learner Feb 22 '16 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.