2

It appears Bind in Ubuntu 15.04 doesn't acknowledge startup options in /etc/default/bind9. I noticed in syslog that bind was trying to resolve ipv6 addresses even with -4 added to Options="-u bind -4" in /etc/default/bind9. When I run sudo systemctl status bind9 it shows the service running /usr/sbin/named -f -u bind with no mention of -4.

I stopped Bind and tried firing bind manually with sudo named -f -u bind -4 and Bind no longer attempts to resolve ipv6 addresses so I don't believe the issue lies with Bind itself. Has anyone run into this issue or have any workarounds?

  • 1
    What does /lib/systemd/system/bind9.service contain? – muru Aug 6 '15 at 2:21
  • /lib/systemd/system/bind9.service has ExecStart=/usr/sbin/named -f -u bind. I changed it to ExecStart=/usr/sbin/named -4 -f -u bind, ran systemctl daemon-reload and systemctl restart bind9 and it now shows up correctly with the -4 option loaded. Is this an oversight by ubuntu or are we supposed to edit files in /lib/systemd/system instead of /etc/default. Thanks for pointing this out by the way. – Snowme Aug 8 '15 at 23:35
  • No, it is not an oversight and you're not supposed to edit files in /lib/systemd/system (or /etc/default, for many cases). I decided this merited a more general post and wrote one here: askubuntu.com/q/659267/158442. If that post makes sense, maybe we can close this as a duplicate of that post. – muru Aug 9 '15 at 3:33
  • 1
    Thanks for the clarification. I backed out my changes and followed your other post which was very thorough and bind is now starting properly using your method. Didn't realize how different systemd was til now. – Snowme Aug 10 '15 at 3:19
0

There is currently a open bug report about the problem which comes also with a workaround.

https://bugs.launchpad.net/ubuntu/+source/bind9/+bug/1565060

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.