6

I installed Wine and tried to install Evernote with it. I got an old install file of Evernote (5.6.4.4632) because this version worked under Ubuntu 14.04. I'm now using Ubuntu 15.04.

When I launch Evernote, an error message pops up, telling me that it can't connect to the server.

So I downloaded Firefox for Windows, installed it using Wine and it has internet access.

I also tried cleaning out my Wine prefix and using a newer version of Evernote (5.8.13.8152) in case the server doesn't accept the old one any longer.

[ I'm aware of the fact that there are alternative clients but I prefer the original application for various reasons. ]

1
  • Same problem here... Evernote_5.8.1.6061 working in 14.10 until 15.04 upgrade, Evernote_5.8.13.8152 can't conect too. I've Wine 1.7.44... But in appdb.winehq.org/… it's reported as working.
    – J.Serra
    Commented Aug 7, 2015 at 13:49

2 Answers 2

6

There is a solution suggested in this post: How to configure wine to install Evernote?, explained further here: instalar-evernote-en-linux (is in Spanish but it has a lot of images)

You could install playonlinux. Once PlayOnLinux is installed, goto manage wine versions, and install wine 1.4.1 32bit.

Then click install program -> install a non-listed program -> Install a program in a new virtual drive.

Give a name for your application virtual drive ("evernote" or whatever you like), then mark Use another version of wine and select the 1.4.1 that you've just installed. Kind of virtual drive I choose 32bit windows installation.

Browse for the installer in your drive, wait for the installation to finish and close Evernote, so PlayOnLinux can notice that the installation has finished.

This works for Evernote_5.8.13.8152 in Ubuntu 15.04.

6
  • Thank you! I read the Wine 1.4.1 thing and tried to install Evernote via playonlinux but didn't choose "use another version of wine" since I assumed it would use the only one I previously installed if I don't choose a different version. However, it used the system version. It works now.
    – UTF-8
    Commented Aug 7, 2015 at 17:47
  • You're welcome, now I'm using wine 1.7.35 and it works too, it didn't with 1.7.44... I also had a problem with note tittles and text in search field, and it solved installing riched20 in install components
    – J.Serra
    Commented Aug 7, 2015 at 19:04
  • So basically the problem happens with some very specific Wine versions and works fine with some other very specific versions ? I have the very same problem with another application. Commented Sep 6, 2015 at 19:37
  • Yes, that was the case with evernote.
    – J.Serra
    Commented Sep 6, 2015 at 20:29
  • I just wanted to post an update to this and say I got evernote version 5.8.5.7193 working with wine 1.7.35 on Ubuntu 15.04. I had to try several version to get it working.
    – techdude
    Commented Sep 25, 2015 at 6:03
4

You need the 32 bit dns resolution libraries. To install this library, run one of the following commands as root:

64-bit Debian 8 : apt-get install libnss-mdns:i386
32-bit Debian or Ubuntu : apt-get install libnss-mdns
64-bit Ubuntu : apt-get install libnss-mdns:i386
32/64-bit Fedora : dnf install nss-mdns.i686
32-bit Mandriva : urpmi nss_mdns
64-bit Mandriva : Not available
32-bit SUSE : zypper install nss-mdns
64-bit SUSE : zypper install nss-mdns-32bit
32-bit Arch : pacman -Syu nss-mdns
64-bit Debian 7 and older : apt-get install lib32nss-mdns

Nothing but wine needs 32 bit binaries as it is mentioned here: https://wiki.winehq.org/FAQ#Why_doesn.27t_DNS_resolve_in_64-bit_operating_systems.3F

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .