0

This question already has an answer here:

Today just when I started installing a new copy of Windows 10 on my laptop I realised that I hadn't retrieved the windows product key from the hard disk.

I quickly took out the USB stick which I was using to install windows and forcibly shutdown my laptop using the power button.

Now I can't boot into Windows so I made an Ubuntu bootable usb stick to access the files from the hard disk but the following message comes up:

Error mounting /dev/sda4 at /media/ubuntu/Data: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=999,gid=999" "/dev/sda4" "/media/ubuntu/Data"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

What can I do in this situation? Is it possible to contact the manufacturer to get the product key?

marked as duplicate by Pilot6, karel, Rinzwind, mchid, Eric Carvalho Aug 6 '15 at 10:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I don't believe it is possible to retrieve the product key if you have had it installed previously. However, you might look in the battery tray or simply the bottom of your laptop for the product key(it's there in most cases). – nixpower Aug 5 '15 at 22:55
  • if you are upgrading from an existing version of windows, I don't think you need a product key to install windows 10. If you don't have an existing legitimate windows registration file (or whatever it uses) on the disk, you would need the product key for windows 10 and not from the old version anyhow (i think). In any case, ms stopped allowing user access to the keys to prevent key sharing so the keys on some windows 8 computers is stored on the device instead of printed on the bottom. – mchid Aug 6 '15 at 10:21
  • " Please resume and shutdown Windows fully (no hibernation or fast restarting)" is not enough information? – Rinzwind Aug 6 '15 at 10:35
2

If windows8, I believe the key is stored somewhere in the system BIOS.

As for accessing the NTFS partition. The problem you have is that Windows was not properly shut down so the Windows system is in a hibernate state. You should properly shut down Windows.

Have you tried using the Windows 10 installation USB to boot up? You could probably start the system up using any Windows installation media. Then, once the system is started up you can shut the system down properly.

You can also usually access a command prompt from the Windows installation media. From there you may be able to run the following command to resolve the issue:

powercfg /h off

Again, you run that command using the command prompt (sometimes called CMD) from the Windows installation media.

After you properly shut the system down, you will probably be able to access your files using Ubuntu if there are some files you need to retrieve before beginning the installation again.

Finally, Windows 10 sometimes has a repair mode or something similar to that you can use to try and repair whatever is left. Also, I believe Windows 10 doesn't require a product key as it verifies the legitimacy of the existing Windows media currently on the device and I believe it matches and verifies your unique device rather than requiring a product code entered manually but I'm not sure.

  • Ehm sorry mchid but answers need to be about Ubuntu. – Rinzwind Aug 6 '15 at 10:36
  • 1
    @Rinzwind this explains what needs to be done in Windows to allow access the NTFS partition when using Ubuntu. This also generally explains some information which may help the user properly identify what data may need to be saved or recovered when recovering data using Ubuntu. – mchid Aug 6 '15 at 10:42
  • thank you so much fot your answer mchid, sorry wasn't able to reply cause got busy. – Hassan Sajid Aug 9 '15 at 17:13
  • anyway, so i tried booting up with my windows 10 installation usb but surprisingly i did not find any shut down button or command prompt so i made a windows 7 installation media with the same usb. and then wen i booted up with it i found that i could access the hard disk from there so i inserted a memory card and copied the product key folder then transferred it to another pc to find the key and i found using the key founder software i would not have been able to do it without your advice so thanks man – Hassan Sajid Aug 9 '15 at 17:26
  • @HassanSajid awesome, you can accept this as the answer to your question by clicking the icon on the left if this answerers your question. – mchid Aug 9 '15 at 17:29
0

Try to use ntfsfix (it's fix common errors and force Windows to check NTFS) by typing :

sudo ntfsfix /dev/name_of_the_partition

In your case :

sudo ntfsfix /dev/sda4

Not the answer you're looking for? Browse other questions tagged or ask your own question.