0

This question already has an answer here:

I am using Lubuntu 14.04.2

I recently updated the xserver-xorg-video-intel-lts-utopic driver from:

2:2.99.914~1~exp1ubuntu4.3~trusty1

To

2:2.99.914~1~exp1ubuntu4.5~trusty1

Now I have randomly missing letters in the desktop icon text and other text in the GUI. I tried reloading the driver from Synaptic but it comes back periodically. The only solution I have found (albeit temporary) is to logout and log back in.

This was part of an update package that has gone awry.

I don't have the proprietary intel drivers installed, nor do I want to.

How do I revert back to the previous driver (2:2.99.914~1~exp1ubuntu4.5~trusty1) where I didn't have this issue?

The command line solution that mchid gave me below should work but I get an error message as seen below.

The solution provided does not have anything to do with my current issue as far as I can tell.

Thx

Nick

marked as duplicate by Pilot6, Eric Carvalho, Rinzwind, A.B., user364819 Aug 6 '15 at 21:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • How did you install this driver? – Pilot6 Aug 5 '15 at 17:06
  • have you tried the vivid hardware enablement stack for lts? – mchid Aug 6 '15 at 1:24
  • The driver was installed through an update. – Treeant34 Aug 6 '15 at 16:41
  • There is no error message below. – muru Aug 9 '15 at 4:21
1

You can use apt-mark hold to prevent a specific package from upgrading to a newer version.

Run the following commands install the version and to hold the package so that it doesn't upgrade:

sudo apt-get install xserver-xorg-video-intel=2:2.99.914~1~exp1ubuntu4.3~trusty1
sudo apt-mark hold xserver-xorg-video-intel=2:2.99.914~1~exp1ubuntu4.3~trusty1

To revert this, run the following command:

sudo apt-mark unhold xserver-xorg-video-intel=2:2.99.914~1~exp1ubuntu4.3~trusty1
  • I think this is what I want, but when I entered it into Terminal I received this: $ sudo apt-get install xserver-xorg-video-intel=2:2.99.914~1~exp1ubuntu4.3~trusty1 [sudo] password for: Reading package lists... Done Building dependency tree Reading state information... Done E: Version '2:2.99.914~1~exp1ubuntu4.3~trusty1' for 'xserver-xorg-video-intel' was not found – Treeant34 Aug 6 '15 at 16:28
  • I did some digging around in Synaptic and discovered it has installed xserver-xorg-video-intel-lts-utopic 2:2.99.914-1~exp1ubuntu4.5~trusty1. I changed the command to reflect this and ran it in terminal. I got the same error though. sudo apt-get install xserver-xorg-video-intel-lts-utopic=2:2.99.914-1~exp1ubuntu4.3~trusty1 [sudo] password for: Reading package lists... Done Building dependency tree Reading state information... Done E: Version '2:2.99.914-1~exp1ubuntu4.3~trusty1' for 'xserver-xorg-video-intel-lts-utopic' was not found. – Treeant34 Aug 6 '15 at 18:00
  • @Treeant34 if you are trying to add the hardware enablement stack, I know the wiki page shows instructions for how to add utopic but since utopic is no longer available you should add the stack for vivid instead. Just replace the word utopic with vivid. As for the old version of xorg, you might be able to download it from packages.ubuntu.com – mchid Aug 8 '15 at 21:02
  • @Treeant mirrors.kernel.org/ubuntu/pool/main/x/xserver-xorg-video-intel/… use wget to download this, use pkg or gdebi to install and use apt-mark to hold it. – mchid Aug 8 '15 at 22:28
  • I gave up earlier today and re-imaged with a previous clonezilla image, then reinstalled the updates minus the xserver-xorg-video-intel-lts-utopic driver. Thanks for all of your thoughts on this though. There should be a way to roll back to a previous driver (like Windows-yeah I know) – Treeant34 Aug 9 '15 at 1:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.