1

After installing w3af with

sudo apt-get install w3af

I'm greeted with the following error when I start w3af:

w3af
Additional information:
pybloomfiltermmap is a required dependency in *nix systems, in order to install it please run the following commands:
sudo apt-get install python2.6-dev
sudo easy_install pybloomfiltermmap

The first issue being that python2.6-dev is not packaged for Ubuntu 14.04, 2.7 is. The second being that the easy_install command results in the following error:

sudo easy_install pybloomfiltermmap
Searching for pybloomfiltermmap
Reading https://pypi.python.org/simple/pybloomfiltermmap/
Best match: pybloomfiltermmap 0.3.14.macosx-10.9-intel
Downloading https://pypi.python.org/packages/2.7/p/pybloomfiltermmap/pybloomfiltermmap-0.3.14.macosx-10.9-intel.tar.gz#md5=bd4bc20376cfceb9e0bb66b49e211f0d
Processing pybloomfiltermmap-0.3.14.macosx-10.9-intel.tar.gz
error: Couldn't find a setup script in /tmp/easy_install-QQQW0T/pybloomfiltermmap-0.3.14.macosx-10.9-intel.tar.gz
2

One solution is to use pip instead of easy_install to install pybloomfiltermmap:

sudo pip install pybloomfiltermmap

But the real solution is to use the package avaliable in the Ubuntu repositories:

sudo apt-get install python-pybloomfiltermmap

Related bug on launchpad: https://bugs.launchpad.net/ubuntu/+source/w3af/+bug/1096580

|improve this answer|||||
1

I also got this error i found a solution u need to install build-essential libssl-dev libffi-dev python-dev before installing pybloomfiltermmap

sudo apt-get install build-essential libssl-dev libffi-dev python-dev
pip install pybloomfiltermmap
|improve this answer|||||
0

I faced lot of issues while installing and running W3af on Ubuntu and the I've come up with the following steps that will help in easy installation.

  1. Install Ubuntu 14.04.5 on VMware player or VirtualBox
  2. Follow the steps mentioned here : http://docs.w3af.org/en/latest/install.html
  3. Note: the dependencies package should be installed of the same version as mentioned when the dependency is missing. Installing latest version might create error. Install the latest version (like new version of pip) only when it is required.
  4. Note: if uninstall fails or is unable to connect to proxy or url, give proxy command::

           –proxy=<proxy address>:<port number>
    
  5. Open terminal and enter the following commands

           sudo -sH
           cd /opt
           apt-get update
           apt-get install git build-essential
           git clone https://github.com/andresriancho/w3af.git
           apt-get install python2.7-dev python-setuptools python-pip
    
          (Or -> apt-get install python2.7-dev python-setuptools python-pip –proxy=<proxy address>:<port number> )
    
  6. run the following command

          cd w3af/
         ./w3af_console
    
  7. You might be asked to upgrade to latest version of pip
  8. Check the version of pip by typing : pip –version
  9. Download the latest version of pip ( tar.gz file)

         Extract the file
         Go to terminal and go inside the pip folder 
         Enter sudo –sH ( command for root)
         Enter  : python setup.py install
         This will install latest version of pip
         (or download get-pip.py file and run this file in cmd)
    
  10. Now enter the command : ./w3af_console
  11. Then we try to run the w3af_console command, which will most likely fail because of missing dependencies. This command will generate a helper script at " /tmp/w3af_dependency_install.sh " that when run will install all the required dependencies.
  12. Now check the file : w3af_dependency_install.sh for all the missing dependencies
  13. Copy those command and run them in terminal ( inside opt folder , with –proxy mentioned)
  14. Install the missing dependencies
  15. Write command : python ez_setup.py install. ( this is for installing the setup tools. Latest version )
  16. download vulndb – installation error.
  17. Inside vulndb folder. Open the setup.py file and change setuptools_git-1.1 to setuptools-git-1.1
  18. Install setuptools-git-1.1. give command: python setup.py install (inside the setup tools git folder)
  19. Now install vulndb. give cmd- python setup.py install ( inside vulndb folder)
  20. W3af is ready to run
  21. Now go inside w3af folder. Enter command : ./w3af_console.
  22. No missing dependencies will be there.
  23. Other Command:

        pip freeze | grep futures    --this command will show the version of futures installed.
        Output of the above cmd: futures==2.1.5
        Pip freeze    -- this command will show all the list of dependencies installed with the specific version.
    
  24. For running: ./w3af_gui , you might be missing a package or dependency. Install those and then run again.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.