The system is Xubuntu 14.04 on an S3J series Asus laptop.

It worked o.k. until it suddenly stopped resolving internet names. As I recall, it happened during an "apt-get upgrade" process. First, I did not know what happened - I was unable to connect to any web page - and I thought I hit the ISP's monthly transfer limit (yeah ...). But when I tried to research the issue (in a new transfer period), it appeared that the net connection is ok, but the system does not resolve host names.

I can ping any external internet address (ie. but I cannot ping "askubuntu.com".

I tried to connect the computer to different networks:

  • via a cable modem (the ISP mentioned)
  • via vlan
  • via gsm modem

and the problem persists in all of them.

And the network manager connection info dialog shows that the dns server addresses are provided through dhcp/ppp.

The /etc/hostname and /etc/hosts files look all right - no unexpected changes there.

The /etc/resolve.conf file contains the "" entry - which is also normal with dnsmasq.

I have reinstalled dnsmasq-base and, after it giving no improvement, am stuck.

I can add that I have another Xubuntu 14.04 system on a desktop computer that has never had such a problem.

I would really appreciate any suggestion about what can be done before the system reinstall.

I have noticed my post is another one in a series of similar cases:

Unfortunately, so far there were no solution for the problem. Perhaps this time?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.