I made the uninformed decision to add a label (and nothing else) to my windows loader partition with GParted.

The GParted entry is: ( /dev/sda1 | fat32 | [no mount point] | [new label] | 900.00 MiB | 47.56 MiB | 852.44 MiB | boot ) if it helps to identify the partition I mean.

Windows 7 no longer boots from GRUB (though its entry remains present), displaying the message: "Setting partition type to 0xb".

I am dual-booting Windows 7 and Ubuntu, and can still boot to Ubuntu.

I do not have the Windows install or repair CD with me.

What should I do?

  • Does your system still boot to Ubuntu? If it does, from the terminal, you can run sudo update-grub to see if it detects the Windows 7 boot and adds it back to the grub loader.
    – Terrance
    Commented Aug 5, 2015 at 13:59
  • @Terrance My system still does boot to Ubuntu. Windows 7 is present on the GRUB loader, but does not boot, displaying the message in the question. I have tried sudo update-grub but Windows still does not boot. GRUB may or may not have changed - I didn't pay much attention to the grub entries before updating GRUB.
    – MadCommy
    Commented Aug 5, 2015 at 14:05
  • It makes me wonder if it is the Windows BCD that is messed up then as to why it won't boot. When you select Windows from grub, by chance does F8 work and you can get into Repair your Computer or Safe Mode?
    – Terrance
    Commented Aug 5, 2015 at 15:37
  • @Terrance I've just solved my problem with the method posted below. I wasn't aware of the F8 option before so you've taught me something there! I might try that next time should I encounter this again. Thanks for your time and advice!
    – MadCommy
    Commented Aug 5, 2015 at 16:38
  • Cool! I'm very happy you got it fixed! =) Have an awesome day!
    – Terrance
    Commented Aug 5, 2015 at 16:39

1 Answer 1



Following advice from here, I downloaded and created a Windows 10 installer usb (which is free) and repaired the Windows bootloader from the installer command prompt:

bootrec.exe /fixmbr
bootsect.exe nt60 all /force

This allowed me to boot from windows again.

I then created an Ubuntu live usb; and installed and ran the boot-repair app to reinstall GRUB:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

This worked for me.

Not the answer you're looking for? Browse other questions tagged .