Neither is my OS virtualized inside VirtualBox nor do I have any VirtualBox packages installed (at least no packages matching "virtual" or "vbox").

Still, on every boot up (in the end of the phase displaying the gnome foot and the 3 blinking dots) the following message pops up in the upper right corner:

VBoxClient: the VirtualBox kernel service is not running. Exiting

I believe this causes boot delays.

  • Since about a week I have the same error on login. I used Ubuntu 14.04 withe the default Unity Session. Every time after login the error message pops up. My system boots straight from the powerup, not vitualized and I installed no virtualbox software or the like.
    – Brutus
    Dec 1, 2015 at 16:37
  • Related question - askubuntu.com/questions/642991
    – pds
    Aug 7, 2017 at 6:36

10 Answers 10


I had the same trouble. Because no virtualbox was installed, i typed on terminal as root " locate virtualbox" and I could see ' virtualbox-guest-utils' & 'virtualbox-guest-x11' VBox in '/etc/init.d. But the troubles remained, because there is another file to delete in /etc/X11/Xsession.d/98vboxadd-xclient. Only deleting it as root, I finally eliminate the message. I suppose that the truble is connected with deleting wine ochanging it in some way


Solved this problem in Ubuntu 16.04, pay attention to the purge command which deletes configuration files

sudo apt --purge remove 'virtualbox-guest-*'

I've found it here

  • 2
    This is the right solution. If you are not inside a virtual environment those packages make a mess!
    – MaxV
    May 30, 2017 at 20:50
  • 2
    I also had to do /usr/sbin/vbox-uninstall-guest-additions
    – Ryan
    Mar 24, 2020 at 18:23

I moved an ubuntu 15.10 VM from Virtualbox v5, where it had a good install of virtualbox guest additions, to VMWare via export-import. Once running under VMWare I apt-get remove'd all the virtualbox* packages, removed /etc/init.d/virtualbox-guest*, removed /etc/xdg/autostart/vboxclient*. Yet the mssage still appeared, hmm.

Finally found the directory /opt/VBoxGuestAdditions-5.0.8 which contained the file uninstall.sh. Ran that script with sudo, and then that damn message stopped appearing at login time. After the script was done, that directory was empty. However, some kernel modules are left; e.g., /lib/modules/4.2.0-22-generic/kernel/ubuntu/vbox

  • I moved a Virtualbox VM to a real machine using Clonezilla and started getting this message. I tried other solutions on this question and in the question that this was closed as a duplication of, but only your solution worked to get rid of it. Thanks!! It's going in my bag of tricks. Feb 27, 2020 at 19:23

I modified the script that causes the popup and it works great. Enter into the terminal. type: sudo gedit /etc/X11/Xsession.d/98vboxadd-xclient

now your editor will open up with the script. look for the following script lines.

if test -f /proc/modules && ! grep -q vboxguest /proc/modules 2>/dev/null; then
# Do not start if the kernel module is not present.
notify-send "VBoxClient: the VirtualBox kernel service is not running. Exiting."

Where it says notify-send change it to say echo then save. the new lines should look like this.

if test -f /proc/modules && ! grep -q vboxguest /proc/modules 2>/dev/null; then
# Do not start if the kernel module is not present.
echo "VBoxClient: the VirtualBox kernel service is not running. Exiting.

Now exit and restart works perfect.

  • 2
    Just disabling a warning does not solve anything!
    – philsf
    Feb 17, 2016 at 17:03

I had the same issue, and I deleted all known files, and directories, but still kept getting the pop up messages. I finally ran across this link :


The info that worked were the first 2 lines of these Sudo Commands, the rest were all ready done manually by me.

sudo find /etc -name "*vboxadd*" -exec rm {} \;
sudo find /etc -name "*vboxvfs*" -exec rm {} \;
sudo rm -r /usr/src/vboxadd-*
sudo rm -r /usr/src/vboxvfs-*
sudo rm /usr/sbin/vboxadd-timesync
sudo rm /lib/modules/`uname -r`/misc/vboxadd.ko
sudo rm /lib/modules/`uname -r`/misc/vboxvfs.ko

Had the same issue. Popup comes up and I have never used Vbox.

MY FIX: ( for Linux Mint )

deleting 'virtualbox-guest-utils' & 'virtualbox-guest-x11' VBox in '/etc/init.d' seems to have stopped the popup message.

  • Can you recall the names of the two vbox files that you had deleted? Dec 19, 2015 at 20:35
  • 2
    At the time of the post I couldn't recall. Checked another Linuxmint PC and got the names for you. Hope it helps.
    – Juddersnz
    Dec 20, 2015 at 19:34
  • I wonder what could have installed those. I do not see tham in any of my current systems. Dec 20, 2015 at 20:19
  • Maybe leftover from a previous installation
    – donquixote
    Dec 20, 2015 at 20:20
  • Sorry it didn't help you. Wonder if you could install VirtualBox then remove it might solve the problem? Guessing you have checked your Startup applications?
    – Juddersnz
    Dec 23, 2015 at 1:03

I run Ubuntu 14.04 with a number of Virtualbox VMs. None of the answers in this forum worked. But this solution which I found on a Linuxlite worked: https://www.linuxliteos.com/forums/other/vboxclient-the-virtualbox-kernel-service-is-not-running/msg19295/#msg19295

You need to edit: /etc/X11/Xsession.d/98vboxadd-xclient (with any text editor) Find the line: 'notify-send "VBoxClient: the VirtualBox kernel service is not running. Exiting." ' Replace 'notify-send' with 'echo' Save.


Actually I experinced the same issue today when installing Ubuntu MATE 16.04 LTS beta into a vbox running under Ubuntu 14.04 LTS with vbox version 5.0.16.

Installing build-essential with re-installing vbox guest additions on the client as described above resolved the problem.

It now works !


To get rid of this message, what worked in my case was to close the vm, upgrade to the latest version of Virtual Box, start the vm, insert Guest Additions CD image, run it, restart.


I just had the same problem, then realized that I didn't have the build-essential package installed. So the guest additions were only partially active.

sudo apt-get install build-essential

then Mount your guest additions and run them. Double check the install log to see if it found make and gcc and was successful.

Then hopefully your error should be gone.

  • @fret is saying that he doesn't have any virtualbox installed then how can he install guest additions
    – user464934
    Nov 28, 2015 at 8:24
  • for me build-essential is already installed, still got the same error.
    – Brutus
    Dec 1, 2015 at 16:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.