0

I'm trying to dual boot windows 10 and ubuntu 14.04. I want to use windows for gaming and ubuntu for everything else. The specs for my machine are here http://pcpartpicker.com/p/KvRjMp.

Windows 10 is installed just fine using a dvd. I have successfully installed ubuntu 14.04 on my old laptop with no issues using a live-dvd. Using the same live-dvd on my new desktop seems to get the best results but still does not work. When it loads it gets to the purple screen with the symbols at the bottom. Then it turns black with _ flashing in the top left. A second or two later I can hear the little bongo roll sound that happens when it loads up but it just hangs with the flashing _. This leads me to believe it's a graphics issue with my gtx 970 but I don't really know anything.

I have also tried using a live-usb created with the startup-disk tool created with the old laptop with ubuntu on it. This produces the exact same result as using the dvd. I also tried using unetbootin and wubi to no avail. When I select the ubuntu installation it loads for a few seconds and I can arrow down to Install ubuntu but it throws me out into an error saying something like chipset not recognized or something like that. I have also tried creating a new partition on my second hard drive and installing from there but still no go. I also turned off fast boot in windows power settings. It seems my machine really doesn't want ubuntu haha.

I really love ubuntu and am dying to get it running on my machine. Should I maybe downgrade to windows 8? Maybe the motherboards uefi is messing with it some how? I'm pretty much at a loss as to what to do here. Any help would be appreciated!

  • Uefi definitely isn't Ubuntu friendly. You might want to switch off the secure boot. Also I'd try getting to live cd and when purple screen appears press esc or shift ( dont recall which exactly ) and you should get to boot options. There you can choose acpi=off. That all I can suggest of the top of my head – Sergiy Kolodyazhnyy Aug 5 '15 at 6:11
  • You see the first answer here askubuntu.com/questions/152847/…, following this and choosing no mode set allowed me to get past a no video problem with nvidia gpu, try setting it, try @Serg suggestion here too by setting acpi=off let us know how it goes – Mark Kirby Aug 5 '15 at 6:14
  • If the computer has anything resembling cutting-edge hardware, the drivers could just not be ready for it. Try loading either 14.04.3 or 15.04 and see if your luck is any better. – aaaantoine Aug 7 '15 at 2:26
  • That was it aaaantoine! Made a live usb with 14.04.3 and it installed perfectly! No special boot modes needed. Thanks to everyone else for the help to. – MfJonesy Aug 8 '15 at 18:03
0

Also, make sure you turn off QuickBoot or FastBoot in your BIOS. I had the purple screen issue with Win 7 and Ubuntu last year and that's what ultimately fixed it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.