0

I recently dual booted Ubuntu version 15.04 alongside Windows 10 on my Dell Inspiron 3451. I got the .iso file from Ubuntu's main site, and I used a live USB install in UEFI mode.

I am a new Linux user, and this is my first time using the OS. My problem is that even though I selected an English locale, and English default languages, I still have folders and menus that appear in Chinese. When I go to my Language Support settings, I have a handful of default English variations at the top, and Chinese all the way at the bottom. Going to the install/remove languages tab, The only two languages selected are English, and Chinese. I try to uncheck Chinese to uninstall, but the window simply grays out and the cursor changes into a loading wheel until I get tired of waiting and close the window.

I tried pretty much everything. Doing some research, I found that you can change this via the terminal, using sudo apt-get install localepurge, except, I have no idea whatsoever how to actually SELECT the two options that I need (en & en_US). When I press enter, the window closes and a command runs, I try to shift/ctrl + 8 for an asterisk, yet that doesn't work either. Can someone give me some insight on this?

It seems like no other options are working for me. Half of the stuff is in Chinese and the other half English. I would just like to completely remove Chinese from my system so that I can try to enjoy this OS. Any help or insight will be greatly appreciated. :)

Also, please assume that I don't know anything about this OS. I can follow terminal instructions, though. Thanks!

EDIT: The results of sudo locale is:

LANG=en_US.UTF-8 LANNGUAGE=en_US

All Other lines have values of en_US.UTF-8

  • Welcome to Ask Ubuntu! Did you install Ubuntu Kylin or the 'default' Ubuntu? If you wanted your system in English, why did you even choose Chinese in the first place? – s3lph Aug 4 '15 at 21:21
  • I have Ubuntu Kylin. I'm not sure what you mean why did I choose Chinese. If Kylin is the chinese version, I wasn't aware that it was when I got it from the site. If that isn't what you mean then can you explain? – Tre Aug 4 '15 at 21:50
  • hmm, i see what you mean now that I looked it up after your comment. I didn't intentionally get Kylin knowing it was the Chinese version. It was on their site, with no explanation that it was the Chinese version (I thought that it was a codename). Is there a way to change this, or will I have to redo everything from scratch? – Tre Aug 4 '15 at 21:53
  • I think Ubuntu Kylin is shipped with some components which are in Chinese only, but I'm not quite sure. It sounds to me as if the easiest way to fix it is to grab the standard ISO and install it over the current install. But before you do that, can you please edit your question and include the output of the locale command. – Gunnar Hjalmarsson Aug 5 '15 at 0:23
  • Thanks for the reply, I updated the OP. Also, I think it would be good to reinstall into the proper Ubuntu 15.05, but I am unsure how to do this safely. Any insight? – Tre Aug 5 '15 at 1:07
0

What you've installed is Ubuntu Kylin, which by default comes with Chinese locale. As with any Ubuntu flavor you can do the following in terminal:

  1. sudo apt-get install language-pack-en
  2. sudo update-locale LANG=en_US.utf8
  3. check-language-support | xargs sudo apt-get install
  4. reboot

If that still doesn't help you, you may want to create live usb for original Ubuntu and install that

More info on locales: https://help.ubuntu.com/community/Locale

  • 1
    A reboot? o_OO really? – A.B. Aug 5 '15 at 4:37
  • @A.B. I had to reboot for sudo update-locale LANG=en_US.utf8 take effect , so yeah . . . – Sergiy Kolodyazhnyy Aug 5 '15 at 4:40
  • Uhmm.. There is a GUI - Language Support - to handle such stuff. Using Language Support prevents you from doing stupid mistakes, for instance forgetting to change the LANGUAGE variable, which is typically set in Ubuntu and overrides LANG for the GNU compatible programs. – Gunnar Hjalmarsson Aug 6 '15 at 22:40
  • @GunnarHjalmarsson OP has tried gui but it was graying out. Besides, I usually answer with what works and what I tested myself. Hence command line answer – Sergiy Kolodyazhnyy Aug 7 '15 at 0:49
  • Sure, there is more than one answer style. ;) As regards the OP's failed attempt to remove Chinese, I suspect it's due to an installer bug (the presence of the folder /usr/share/locale-langpack/zh). – Gunnar Hjalmarsson Aug 7 '15 at 10:05
0

I ended up removing the Ubuntu partition from my computer and using a recovery disk to reset the Windows bootloader. Then I went through the same steps, but this time I used Linux Mint (which is what I was going for originally anyway). Everything works properly now! Thanks for the help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.