1

I currently have one terminal open with 10 tabs. How do I modify the way I move between the tabs on Ubuntu?

If you are not sure what I mean, then let me give this example. On Firefox, if I have 10 tabs open, I would press ctrl + tab to move between the tabs. On the terminal, I just checked the shortcut and it's ctrl+page down to move to the next tab. Well this is not good for me. How can I change it to ctrl+tab?

  • What Terminal app are you using? gnome-terminal? – user364819 Aug 4 '15 at 19:35
  • Just the default terminal. I've got to re-phrase this question as I just realised something. – john smith Aug 4 '15 at 19:36
  • The default Terminal depends on your flavour of Ubuntu, if just the normal Ubuntu though it will be gnome-terminal. – user364819 Aug 4 '15 at 19:37
  • Try Ctrl + page up and down – ElefantPhace Aug 4 '15 at 19:37
  • Thanks, I just realised this. I need to change it to something different. – john smith Aug 4 '15 at 19:38
1

In Gnome Terminal you can use :

  • Cntl + PgDn to move between tabs from left to right

  • Cntl + PgUp to move between tabs from right to left

Answer to the edited question :

To change teh key mappings for switching betwen terminals go to

Edit > Keyboard Shortcuts...

Then change it like the picture is showing :

Keyboard Shortcuts_Gnome terminal

As you can see i have changed the mappings to < and >.

  • How do I modify the shortcut to use ctrl+tab? In the options, it doesn't seem to like me changing it to something more than 1 button. So when I change it to, lets say "p". The I can use p to move right onto the next tab. But when I click the option and try to change it to a new accelerator (that's what it says when you click to change the shortcut), it doesn't allow me to press ctrl with tab. – john smith Aug 4 '15 at 19:41
  • @johnsmith check my edits ..also dont change your question on the fly..its totakkt diffferent from the initial question now.. – heemayl Aug 4 '15 at 19:57
  • My initial question hasn't changed. I modified it about 60 seconds after I created it as the question was wrong. Anyways, I still can't use ctrl+tab to move between my tabs. It's like the settings won't allow me to do such a binding. For now I've just bound it to ctrl+1, since that's as close to ctrl+tab as I can get and make it work. – john smith Aug 4 '15 at 20:02
  • @johnsmith Seems so..i cant do that too.. – heemayl Aug 4 '15 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.