6

When I run sudo apt-get update on Ubuntu 15.04, I get the following (shortened) output:

$ LANG=C sudo apt-get update
[sudo] password for ipc-admin: 
Ign http://ftp.uni-stuttgart.de vivid InRelease
Ign http://ftp.uni-stuttgart.de vivid-updates InRelease
.
.
.
Hit http://ftp.uni-stuttgart.de vivid-proposed/universe Translation-en
Hit http://ftp.uni-stuttgart.de vivid-proposed/universe Translation-de
100% [Working]

Then it gets stuck and won't continue until I interrupt it with Ctrl+C.

When I do sudo aptitude update instead, it also hangs at the same position.

After deleting the cache with sudo rm -rf /var/lib/apt/lists and running sudo apt-get update again, I still get the same results.

However, it seems to have successfully updated the package index files after running sudo apt-get update and interrupting it when it gets stuck, as I still can run apt-get upgrade and receive new updates, or apt-get install. It just does not finish the apt-get update task...

A reinstall of apt with sudo aptitude reinstall apt and a reboot afterwards did not change my situation either.

What might be the problem here and how can I fix it?

PS: The full output of apt-get update recorded with script that also shows those dynamic lines may be found on pastebin.


UPDATE

After letting it run for hours, it actually finishes! The repositories that cause the problem are various https://repo.tox.im lines. Here what appears after loooong times of waiting between each line:

Ign https://repo.tox.im nightly InRelease
Ign https://repo.tox.im nightly Release.gpg
Ign https://repo.tox.im nightly Release
Err https://repo.tox.im nightly/main i386 Packages
  Connection timed out after 120000 milliseconds
Ign https://repo.tox.im nightly/main Translation-en
Ign https://repo.tox.im nightly/main Translation-de
Fetched 69,8 kB in 36min 0s (32 B/s)
W: Failed to fetch https://repo.tox.im/dists/nightly/main/binary-i386/Packages  Connection timed out after 120000 milliseconds

E: Some index files failed to download. They have been ignored, or old ones used instead.

After this, the process terminates correctly without having to interrupt it. So what can be the problem with that repository and how may I fix it?

  • 1
    You should try: # sudo -s -H # apt-get clean # rm /var/lib/apt/lists/* # rm /var/lib/apt/lists/partial/* # apt-get clean # apt-get update – user364819 Aug 4 '15 at 19:19
  • @ParanoidPanda Did not work... :-( – Byte Commander Aug 4 '15 at 19:30
  • 1
    @ParanoidPanda It's the exact same base, installing GNOME won't help it. Also, this isn't the place for stuff like this - especially not in multiple comment-form. – RPiAwesomeness Aug 4 '15 at 19:33
  • @ParanoidPanda Yes, reinstalling might resolve this. However, I would still wait and see if there's more responses. – RPiAwesomeness Aug 4 '15 at 19:38
  • I had the same problem a while ago... Just try to switch to other server closer to you and it might work out just fine. – JoKeR Aug 4 '15 at 20:42
6

After having waited for the command to complete for hours, I saw that it hangs on all tox repositories.

I checked their main page and found out, that the whole infrastructure including repositories, wiki and main site moved to a different domain. That's why the old URL is not alive any more and why apt-get update is timing out.

On their new wiki, they gave the following (slightly modified) script to install the actualized repository:

#!/bin/bash
sudo apt-key del 0C2E03A0
sudo sh -c 'echo "deb https://pkg.tox.chat/debian nightly main" > /etc/apt/sources.list.d/tox.list'
wget -qO - https://pkg.tox.chat/debian/pub.gpg.key | sudo apt-key add -
sudo apt-get install apt-transport-https
sudo apt-get update
echo "Tox Repository Installed. You can now install qtox"

I executed those lines and now all problems with apt-get update are gone!

Unfortunately, the new repository does only contain 64bit builds of qTox yet, so I will have to live with that package being hold back for a while, until they also compile it for 32bit machines!


WARNING: If you have 32bit qTox installed, do not install the new repository! It contains a 32bit qtox package with higher version number than the last one available, so apt-get upgrade will install it and replace your current qTox installation with that one, as soon as you run updates. But it is not a 32bit package, it just looks like one! Inside it contains 64bit executables!

For more information and a script to verify the package's true architecture without having to install it, see my Q&A here!

The last repository update fixed this and qTox is now available for both architectures again! :)

1

I recognized this problem from time to time and from amchine to machine. I got rid of it by simply changing the to main mirror server - called in the german version you are using "Haupt-Server" enter image description here

Since I changed away from "German Servers" to "Main Server" everything is fine...

  • Might be more secure in general, but would not have solved my specific problem, as it was a third-party repository and therefore not affected by this option. Besides, regional German servers are faster than the main server, so I won't change. – Byte Commander Aug 16 '15 at 13:53
  • AS I had exactly the problem you described several times Witz the Herman Servers without 3rd Party ppa's I thought I contribute that... 😊 – Mr.Gosh Aug 16 '15 at 14:33
0

First of all, make sure you have chosen proper sources at

/etc/apt/sources.list

Next, you can try what works for me:

cd /etc/apt

In this dictionary, there can be a folder named

sources.list.d

and it contains some config files you don't need.

I edited those config file by adding # in front of each line, and it make sense.

  • Please look at the accepted answer (which I even wrote myself), the problem has been solved for over a year now. – Byte Commander Nov 6 '16 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.