1

I have only been using Ubuntu 14.04 for a few weeks and really enjoying it. My first time using Linux and I'm really impressed at how easy it has been to learn a new operating system while still maintaining functionality for my daily tasks.

However, I spent extra cash on this machine for the video card. I can play the games I want on linux but I am not getting the performance I should be.

Installing the fglrx using Additional Drivers or downloading the latest from AMD kills the system and I have to use the bootloader to get a command prompt to run apt-get purge fglrx* to get back to a desktop. I suspect this is because the machine isn't using the Radeon card at all and the fglrx drivers are completely wrong for the integrated Intel GPU.

If I run: lspci | grep VGA - Can only see one graphics card

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor 
Integrated Graphics Controller (rev 06)

But sudo lshw -c display shows both:

*-display
    description: Display controller
    product: Mars [Radeon HD 8670A/8670M/8750M]
    vendor: Advanced Micro Devices, Inc. [AMD/ATI]
    physical id: 0
    bus info: pci@0000:01:00.0
    version: 00
    width: 64 bits
    clock: 33MHz
    capabilities: pm pciexpress msi bus_master cap_list rom
    configuration: driver=fglrx_pci latency=0
    resources: irq:16 memory:b0000000-b7ffffff memory:b8000000-b803ffff ioport:4000(size=256) memory:b8040000-b805ffff
*-display UNCLAIMED
    description: VGA compatible controller
    product: 4th Gen Core Processor Integrated Graphics Controller
    vendor: Intel Corporation
    physical id: 2
    bus info: pci@0000:00:02.0
    version: 06
    width: 64 bits
    clock: 33MHz
    capabilities: msi pm vga_controller bus_master cap_list
    configuration: latency=0
    resources: memory:b9000000-b93fffff memory:a0000000-afffffff ioport:5000(size=64)

Additional drivers shows the AMD/ATI using xorg-server-video-ati but the Settings -> Details shows Intel Haswell Mobile.

after I added modeset=1 to /etc/default/grub (updated grub) and with root

cat /sys/kernel/debug/vgaswitcheroo/switch

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

But this does nothing, I still get the same output with the above command:

echo ON > /sys/kernel/debug/vgaswitcheroo/switch

contents of /etc/default/grub

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="modeset=1"

Since adding modeset=1 my laptop is running much cooler. The fan hasn't even come on while I made this post. So I think both cards were powered before but not using the Radeon.

I have been at this for a while now and read many similar questions on this site and tried to use them to help me without success.

How can I take advantage of my Radeon card?

EDIT:

after a reboot I had an error which said xorg crashed with SIBABRT. I thought this might be why I couldn't power up the second graphics card. So I ran sudo dpkg-reconfigure xserver-xorg and received a message saying xserver-xorg was not installed.

If I try sudo apt-get install xserver-xorg the message is unity-control-centre has unmet dependencies - libcheese-gtk23 and libcheese7 but they are not going to be installed. If I try to install them it says the latest version is already installed.

Also tried restarting xserver thinking, there is now way it is not installed, how else could it crash, with sudo service lightdm restart which left me with a black screen. After restarting, there was no xserver crash error but I still can't use vgaswitcheroo. Possibly I can't use switcheroo at all because there's every chance I don't have a hardware mux.

0

Your xorg.conf file may not be configured to use the graphics card. This will configure it after installation.

fglrxinfo

sudo aticonfig --adapter=all --initial --force

| improve this answer | |
  • I get aticonfig: No supported adapters detected Also the Catalyst Control Centre won't run. The error is in German(probably location based) but I'm pretty sure it basically says that it can't detect any ATI hardware. – Eddie Aug 4 '15 at 21:44
  • I found this which suggests the Catalyst Control Centre can easily switch GPU's but it won't start because it doesn't detect an ATI card. – Eddie Aug 4 '15 at 23:22
  • I have reinstalled ubuntu and still have the same problem. – Eddie Aug 10 '15 at 19:16
  • Is it possible this is the drivers issue again? or is it a bad card? – user200348 Aug 11 '15 at 12:44
  • It's not a bad card as it works fine with Windows. – Eddie Dec 7 '15 at 21:40
0

You can try and turn off the switchable graphics in the BIOS:

Reboot your computer, enter the BIOS settings and change them from:

  • switchable graphics
  • Hybrid graphics

... to:

  • UMA graphics
  • On-board graphics
  • Intel Graphics

...

after that, it will be possible to use the Intel video card only with proper drivers on Ubuntu.

Here is the source of my material

| improve this answer | |
  • Using the Intel card was never the problem. It is used by default. I wanted to use the radeon card for games. In the end I set up dual boot with Windows. – Eddie Nov 27 '15 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.