0

This question already has an answer here:

Using Virtualbox 5.0 with Windows 8.1 as host and Ubuntu 14.04.2 as guest. It is extremely slow. I have tried

1) Increasing the RAM size

2) Used multiple processors in Systems->Processor tab (have IntelCore i7 processor)

3) Enabled 3D Acceleration in Display->Screen tab

4) Increased the video memory

5) Tried enabling/disabling Extended features in the settings

6) Also tried Ubuntu-15.04 (behavior remains the same)

Here's (Why does a Ubuntu guest in VirtualBox run very, very slowly?) from a user some time back.

The system is still slow...is there anything to be done in the BIOS? and i doubt it, as my windows is pretty fast. Any help appreciated! (Thanks!)

marked as duplicate by bain, Eric Carvalho, David Foerster, Charles Green, Evandro Silva Jan 19 '16 at 18:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you tried to install VirtualBox Guest Additions ? – hg8 Aug 4 '15 at 9:09
  • Did you install guest additions? – Pilot6 Aug 4 '15 at 9:09
  • Have you tried changing the virtual machine's chipset? – Sledge Hammer Aug 4 '15 at 9:12
  • Thank you guys for the comments and suggestions ( I will work on them in a shortwhile). i am trying to re-install now the Ubuntu guest, and its been an hour and its still going on. – Muzab Aug 4 '15 at 9:16
  • 1
    Did you enabled VT-X hardware acceleration on your BIOS and VM config?, also maybe you're using a x86 guest ubuntu instead of x64. – bistoco Aug 4 '15 at 9:21
1

Edit:

Alright, so it was kind of my bad. After installation I did my first sudo apt-get update and realized my network connection wasn't working correctly. It was due to the way I set up my VM where I set the network adapter to attach to bridged network. This must've had caused the installation process to choke up like that. When retrying installation I left the VM settings to standard and every was smoof. Hope this is helpful to someone out there.

I feel your pain. If indeed the issues you're referring are:

  • During the beginning of installation everything seems to run fine
  • further in the installation things starts to look like frozen
  • wait long enough (15+ min) to see progress
  • occuring multiple times during installation

To be honest, I have tried to figure it out. No it's not the 3D hardware acceleration. It seems to me like it is the Paravirtualization Interface which I have set both to KVM and Hyper-V for testing but in both cases the issues persists. I stopped trying other settings once I got my Ubuntu 14.04 Server setup because I couldn't risk another hour of waiting for the installation to complete, it's ridiculous.

So my best guess is try either setting your System > Acceleration > Paravirtualization to anything other than I mentioned above, or System > Motherboard > Chipset selection somewhere?

Not the answer you're looking for? Browse other questions tagged or ask your own question.