16

If i try to open any of partition, I get error message in a box.

Error mounting /dev/sda8 at /media/viratraaz/Documents: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda8" "/media/viratraaz/Documents"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda8': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
0
20

You need to disable Windows fast start-up option.

Open Control Panel -> Energy Settings and select Change what the power buttons do.

Choose Change settings that are currently unavailable, scroll down and uncheck
Turn on fast start-up (recommended).

Restart the computer and you won't have this error anymore.


See here for more informations about Windows Fast Boot.

12

It happens because of the partial hibernation of Windows (From Windows 8). I hope you are trying to open a drive from your dual booted system which is shutdowned from Windows last time.

A quick and dirty way to fix this problem is, executing the following command on each drives:

sudo ntfsfix /dev/sdxx

where xx is device and partition letter and number ie: /dev/sda1

For more details: WORKAROUNDS FOR NOT BEING ABLE TO MOUNT THE WINDOWS 8 PARTITION IN LINUX DUE TO HIBERNATION

2
  • Can't imagine why this is a dirty way because it's using the special utility even named ntfsfix.
    – StalkAlex
    Jul 30 '16 at 15:36
  • 1
    The reason for dirty is here: According to the manual, ntfsfix - fix common errors and force Windows to check NTFS". However, this problem occurs not because of errors but because of hibernation. For more details: disq.us/p/yajyhr
    – Gobinath
    Aug 1 '16 at 3:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.