I followed this question:

How to add my favorite places as a quicklist in my home's icon in Unity?

And created the launcher. It's pretty good, as you can see here:

But when I click it (be 'it' itself or any of the shortcuts) another launcher, the dull one, gets to represent nautilus in Unity, as you can see here:

I even backed nautilus.desktop up at /usr/share/applications so and then copied my custom launcher to this system folder --- but it still doesn't work!!!

So, what can I do?


I did't copy /usr/share/applications/nautilus.desktop to ~/.local/applications and just worked on the original file.

gksu gedit /usr/share/applications/nautilus.desktop

Afterwards I pulled the Nautilus/File Manager starter from /usr/share/applications to the launcher. Even worked after a reboot.

As you only add something at the end of the file it's easily reversible.

| improve this answer | |
  • Hmm yeah, you've got a point. I'll try that and get back here. – Peterson Silva Oct 13 '11 at 21:55
  • Couldn't do it. I edited nautilus.desktop, and then I saw there was a "nautilus-home" app. Moved it to my home folder in case that one was being used or something. Still, the same problem. Now I just get a different icon, though. – Peterson Silva Oct 13 '11 at 22:10
  • I reinstalled nautilus with sudo apt-get install --reinstall nautilus to get the original /usr/share/applications files back. When I did, I worked directly over them. I still get the same error. – Peterson Silva Oct 13 '11 at 22:17
  • I finally got it! Once I took the steps previously mentioned (reinstalled nautilus, edited nautilus.desktop directly at /usr/share/applications), I rebooted. Then, instead of using the dash to move the "home folder" launcher to the unity launcher (fig1), I just launched nautilus through a terminal to see which icon would pop up at the unity launcher. The result was this different icon I talked about earlier (fig2). But it had the quicklist, so I kept it in the launcher (fig3) and headed over to nautilus.desktop to change the icon to user-home (fig4). Reboot once more, and it's done! – Peterson Silva Oct 13 '11 at 22:46
  • - fig1: i.imgur.com/7p2mP.png - fig2: i.imgur.com/Uhnh0.png - fig3: i.imgur.com/P5tjN.png - fig4: i.imgur.com/FlAxa.png - fig5 (success!): i.imgur.com/WIclb.png - fig6 (success!): i.imgur.com/jzol9.png – Peterson Silva Oct 13 '11 at 22:51

This is a duplicate of this question. I put a detailed description of the solution there. There is also a bug report.

It is not the nautilus.desktop but the nautilus-home.desktop that you are supposed to modify, I think that's why you had to find another launcher and had icon problems. If you modify /usr/share/applications/nautilus-home.desktop, it works after reboot without any more steps.

| improve this answer | |

There is no reason why you can't use a modded nautilus-home.desktop in ~/.local/share/applications or any other copied & modded .desktop

Actually in many/most cases it's preferred for various reasons.

The issue is that when copying the .desktop there is a line that needs to be removed for it to work correctly from the alternate location.

Just remove this line & it's space from your modded .desktop in ~/local/share/applications. (if the line exists - does in many .desktops


All should be well, if need be log out/in. This is for 11.10 & atm 12.04 pre-alpha

| improve this answer | |

Alright I think I've figured this out. First of all you do need to edit the file in /usr/share/applications/ but the thing is after you've edited it instead of right-clicking on the icon while Nautilus is open and selecting "Keep in Launcher" you need to open up the dash and drag the Home folder icon over to the Launcher instead. For some reason that made it work for me!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.