1

Begginer here.

I recently downgraded my Ubuntu to 12.04.5LTS because I wanted dual monitor support but my hd4870 cant support AMD drivers and stuff.

Once I downgraded it and tried to install the drivers something like "one or more tools required for installation are not on this system" or something.

I looked online and tried a few solutions but none of them work like. I don't remember all that I did but these are among them.

Install headers, 32bit lib.

Log

Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers. /lib/modules/3.13.0-61-generic/build/include/linux/version.h cannot be found on this system. One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

  • This is a wrong advice in this case. Did you see the card model? – Pilot6 Aug 3 '15 at 9:59
  • @Pilot6 hd 4000 on the amd website.Currently downloading ubuntu 12.04 since my mouse cant move in new kernal – Jason John Aug 3 '15 at 10:55
  • There is the legacy diver there. It can be installed from ppa as in my answer. – Pilot6 Aug 3 '15 at 11:01
  • @Pilot6 for 12.04.5?or 12.04? – Jason John Aug 3 '15 at 11:13
  • I explained already that it can't be installed for 12.04.5 without downgrading kernel and xorg. – Pilot6 Aug 3 '15 at 11:26
0

You can not install fglrx-legacy drivers, because Ubuntu 12.04.5 has too new Xorg stack.

You can downgrade Xorg by running

sudo apt-get install xserver-xorg libgl1-mesa-glx xserver-xorg-input-all

You also need to downgrade kernel too. This can be done with

sudo apt-get install linux-generic

Then you will need to boot with kernel 3.2 using grub menu. After that remove all 3.13 kernels using Synaptic.

Then legacy drivers may be installed by

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get install fglrx-legacy

After that you will be able to install legacy AMD drivers that support your video card.

  • one more question, i heard you could downgrade too in ubuntu 14.04LTS.If i have to do this for 12.04LTS ,would it be better to update to 14.04 LTS? – Jason John Aug 3 '15 at 9:18
  • No. There is no good way to use old xorg in 14.04 – Pilot6 Aug 3 '15 at 9:19
  • What does not work? What is the error? – Pilot6 Aug 3 '15 at 9:27
  • same error.I posted log ontop – Jason John Aug 3 '15 at 9:30
  • You need also to downgrade your kernel too. – Pilot6 Aug 3 '15 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.