2

If you boot into an Ubuntu live cd (all flavours), you get full resolution in Parallels. However, once you install it the display is limited to 800x600. The standard solution offered is to install Parallels tools but this has its own side effects and it isn't a solution.

What surprises me is that Debian doesn't have this problem, even though I cannot find any difference in terms of Xorg packages installed.

How can this be fixed? Installing Parallels tools is not the correct solution. I only want display as it is in Debian or Fedora and in the Ubuntu live environment.

Update Ubuntu 12.04 with Unity 2D (and Linux 3.11) works correctly. I tried Xubuntu 14.04 without 3D acceleration but it made no difference.

0

You could use xrandr, a tool which enables you to set your desired resolution through the command-line.

There are several guides on setting up xrandr to work for your display. This article should enable you to set it up correctly - I used it and got xrandr working fine.

Unfortunately, a lot of people have trouble making the commands permanent, so that they run on startup, but I'll show you how to do it the easy way:

  • Create a script, xrandr.sh for example, and place your xrandr commands into it. It should look something like this

    #!/bin/bash
    xrandr --newmode "1920x1200_60.00"  193.16  1920 2048 2256 2592  1200 1201 1204 1242  -HSync +Vsync
    xrandr --addmode VGA1 1920x1200_60.00
    xrandr --output VGA1 --mode 1920x1200_60.00

  • Make the script executable with chmod +x xrandr.sh

  • Search for "Startup Applications" in the dash, run it, and add the script as a startup application.

4
  • Thanks. I am not able to test this right now. But once I do - and assuming it works - I'll give you the 100 points. Having said that, I think I've tried xrandr so don't get your hopes up ;-) – Simon Hoare Aug 7 '15 at 20:28
  • @SimonHoare XD ;D – TellMeWhy Aug 8 '15 at 10:04
  • @SimonHoare I presume it hasn't worked for you... – TellMeWhy Aug 10 '15 at 20:58
  • In fact, I had replaced OS X with Ubuntu (and am now very happy on another Linux) so unfortunately I can't test it anymore. If you can somehow prove beyond reasonable doubt that this does work for Ubuntu on Parallels, perhaps I could put this back up for bounty. – Simon Hoare Aug 11 '15 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.