Background: I'm having issues with the Nvidia ASUS Strix GTX960. I am using Kubuntu 14.04.

I just built a brand new system, upgrading from my laptop with AMD HD radeon. I had K 14.04 on that build and K 14.04 on my new one. I'm using the 352.63 driver (recommended).

I tried using the X-org drivers at first but I couldn't get a solid startup so I switched to the nvidia drivers using the system setting GUI. I also had screen tearing on my old one. Using this article for workoff.

Behavior: When playing games or just scrolling through this post I am noticing ghosting on small test or particles, and heavy screen tearing. The screen tearing happens on both video and movement of still images.


dpkg -l | grep nvidia

rc  nvidia-304                                  304.125-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA legacy binary driver - version 304.125
ii  nvidia-352                                  352.63-0ubuntu0.14.04.1                                amd64        NVIDIA binary driver - version 352.63
rc  nvidia-opencl-icd-304                       304.125-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA OpenCL ICD
ii  nvidia-opencl-icd-352                       352.63-0ubuntu0.14.04.1                                amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                0.6.2                                                  amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                             355.06-0ubuntu0~xedgers14.04.1                         amd64        Tool for configuring the NVIDIA graphics driver

Attempted Fixes:

  • Updated the pciids.

  • Updated and upgraded everything.

  • Added this to my file: xserver-command=X -bs -core

  • Typed in terminal nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

    but the fullpipeline only gave me temporary and sporadic fix.

  • Created xorg.conf file through nvidia xserver

1 Answer 1


Screen tearing was eventually resolved with nvidia meta mode setting in terminal.

Arch wiki article for Nvidia tear fix, scroll down to "Avoid tearing with GeForce 500/600/700/900 series cards".

After the tunnel compost failed to sustain through an entire session I received help in Reddit. After adding the triple buffer feature tearing is either gone or unnoticeable. Also with recent updates framerates have significantly approved, as well as clarity that was reduced through only tunnel composite.

NOTE: in the Nvidia xorg server settings, vsync option is activated and also activated in game options. Also performed system restart and checked BIOS to ensure proper RAM speed.

FIX: Add any of the following not present in your xorg.conf file at /etc/X11/

Section "Screen"

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-0"
Option         "metamodes" "nvidia-auto-select +0+0 {ForceFullComposition = On}"
Option         "TripleBuffer" "1"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24

NOTE: Ghosting has been temporarily labeled as a monitor issue and not that of the card.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .