So here's what happened: I created a ubuntu gnome bootable usb using unetbootin and selected to replace my windows and install a fresh copy of ubuntu. But as soon as ubuntu finished cleaning up windows and formatting i got the error error fsyncing/closing/dev/sda: input/output error

I had no choice so I restarted my system and now my HDD is not detected in BIOS and also not in ubuntu live boot mode.

I have a Sony vaio.

Any ideas how I can fix this?

3 Answers 3


I/O errors usually (but not always) indicate failing hardware. My guess is that your disk (or some other disk-related component, like a cable or your motherboard's disk controller circuitry) was on its last legs, and the "exercise" involved in installing Ubuntu caused it to fail. You don't say what prompted you to install Ubuntu, but if you were having problems with Windows reliability, it's possible that this was an earlier symptom of the problem.

You might try unplugging your disk (from both ends of the cable if it's a desktop system) and plugging it back in again. You could also try running a SMART test from an Ubuntu live CD -- but if the disk isn't detected by your firmware, it might not even show up in Ubuntu, which would make such a test impossible.

If you've got a spare disk, you could try using it instead. If it works, then you can pretty much conclude that your old disk is dead. If the replacement disk fails, too, then chances are the problem is with your computer motherboard's circuitry.

  • I tried to install ubuntu as my windows installation has gone painfully slow. Even a click on my computer was taking like forever to execute. Luckily linux mint was installed after several attemps though with too may errors. What you say is absolutely right as both badblocks and mint's disk utility show poor disk health. The message says and I quote failure is imminent
    – ares
    Aug 3, 2015 at 17:07
  • 2
    In that case, power down the computer immediately. You can then go to a computer store and buy a new replacement disk; or if you can go without the computer for a day or two, order a replacement online. See this question and answer for instructions on copying your system. (If this is a laptop, you may need a docking port or USB/SATA adapter to temporarily connect the disk, or use a desktop system to do the copying.)
    – Rod Smith
    Aug 3, 2015 at 21:34
  • I don't think this is entirely correct for Raspberry Pi running Raspbian Linux. My SSD drive is in good shape, and is connected through a USB converter. Yet, I get this error when trying to rsync linux boot files to it. Jun 5, 2016 at 19:35

Try to replace older cables and defective HDD

It worked for me. However, similar happened when I was performing Debian 10 installation.


If you encounter that problem you definitely have a defective HDD or a problem in the partitions Encountered the error when trying to instal bionic beaver when Windows failed to boot on the laptop.. I had to re instal Windows to organize the dis partitions then installed Ubuntu and wiped the windows data in the process

It worked!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.