After an Update to Ubuntu 14.04, the system no longer started and showed the grub rescue prompt. I was able to start from CD by pressing F10 at the beginning to select the boot medium. Then I was able to boot Ubuntu using the Super Grub Disk, updated the Boot-Repair program and started it. error symbol 'grub_term_highlight_color' not found

I updated grub, boot-repair and the system: sudo apt-get update sudo update-grub sudo boot-repair

and somehow repeated application of Boot Repair managed to break the UEFI Windows Boot process entirely. Now Windows 8 no longer boots, no matter what I do. It returns the errors EndEntire error: premature end of file.. or EndEntire error: cannot load image... The EFI/UEFI boot process for Windows is completely broken.

What I can do to boot Windows again? :-/

Here is the current output of Boot-Repair http://paste.ubuntu.com/11985798/

  • Original highlight color issue on grub update is related to update of grub to wrong boot version or related to fixes you may have done to make it work with a Samsung as Samsung is one that will not directly boot Ubuntu entry in UEFI in efi mode. You may have had BIOS boot and booted directly from UEFI menu or copied grub to bootx64.efi. But now may need to recopy it. At this point best may be Rod Smith's solution of rEFInd. – oldfred Aug 2 '15 at 20:45

The EndEntire error: premature end of file and EndEntire error: cannot load image messages might indicate a problem that needs to be fixed from the Windows side -- namely, damage to the Windows boot loader. (OTOH, if you have a backup of your EFI System Partition, or ESP, from before the error occurred, you may be able to recover by restoring that backup. IMHO, such a backup should be made as a matter of course both before and after installing Ubuntu -- but that's another matter.) If I'm right about this, you'll need to get your hands on a Windows recovery disk, use it to fix the Windows boot loader, and then re-install a Linux boot loader or change the boot order so that what you've got now boots first.

I also recommend you re-read my second response to your answer to your earlier question. In particular, prepare a rEFInd USB flash drive or CD-R and try booting with it. This tool (which I maintain) can boot Ubuntu without GRUB, and can chainload to the Windows boot loader, so if GRUB is acting up, rEFInd can provide a workaround -- either temporary or permanent.

Disclaimer: I'm not a fan of GRUB 2. It's a bloated pig of a program with a finicky configuration file that's so difficult to maintain that GRUB provides a series of scripts to perform that task. The result is like a house of cards -- it holds together OK under optimal conditions, but if anything about your configuration is sub-optimal, the whole thing will come tumbling down and be difficult to put back together again. FWIW, my disaffection with GRUB 2 is what motivated me to fork the earlier rEFIt into rEFInd. GRUB 2 has improved since that time, but the fact that I took on maintenance of an open source boot manager rather than deal with GRUB 2 should say something about GRUB 2's problems, at least in my eyes.

  • Thanks for your help, the Boot-Repair people do not want to help unless you spend an undisclosed amount of money :-( Very unpleasing. I tried to put rEFInd on an USB stick an with UNetbootin, and was able to start it. It says when I try to start Windows 8: "Starting bootmgfw.efi. Error: unsupported while loading bootmgfw.efi". – 0x4a6f4672 Aug 8 '15 at 20:13
  • That error suggests that the Windows boot loader (bootmgfw.efi) has been damaged. If you're lucky, you might find a backup on the ESP itself, but chances are you'll need to use Windows emergency tools to repair it. – Rod Smith Aug 8 '15 at 21:48
  • How would such a backup look like? What is an ESP? – 0x4a6f4672 Aug 10 '15 at 8:23
  • Sorry -- ESP is the EFI System Partition, which is normally mounted at /boot/efi in an installed Linux system. A backup could be anything, but look for a file with a similar filename, like bkpbootmgfw.efi; or an entire backup directory, like EFI/MS-backup. – Rod Smith Aug 10 '15 at 13:39
  • I hate this EFI stuff. Secure Boot sounds nice, but if it is so secure that it prevents you from booting then it sucks :-( :-( :-( – 0x4a6f4672 Aug 10 '15 at 14:23

The problem that I had was the corrupted bootmgfw.efi file. To restore that create a bootable windows 10 usb (https://www.microsoft.com/en-us/software-download/windows10) and boot into the recovery mode. Click Troubleshoot > Command Prompt. Copy the file C:\Windows\Boot\EFI\bootmgfw.efi to some other location like C:. I had a dual boot computer so I then rebooted into linux and copied the recovered bootmgfw.efi file into \EFI\Microsoft\Boot. This solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.