2

This Reddit article sums it up: Why isn't there a wireless controller that can wake a PC up?

When I play games in Steam, my computer doesn't recognize that I'm mashing buttons and it goes into sleep/suspend mode. I don't want to disable power management or use wake on LAN. Is there any other way to get my computer to recognize my gamepad's input and not go to sleep? I'd also like to wake my HTPC with the controller.

The Logitech F710 and the Xbox 360 wireless controller are HID-compliant in Windows but not Linux (see screenshots below). FYI, the Logitech F710 is HID-compliant in Xinput mode, but not in Directinput modes.

enter image description here

I ran "lsusb -v" and have screenshots below for the mouse, Logitech F710, and the Xbox 360 wireless controller. This shows how the mouse registers as a HID-compliant device and how the controllers don't.

enter image description here

I'm running Ubuntu 15.04 with the LXDE desktop on my Kodi/Steam-box. My motherboard is an Asus 990fx r2.0, which only has "Power On By PME Device" and "Power On By Ring" (I've enabled both). The bios also has "Power On By RTC" but that's disabled. I've also plugged the controllers into USB3 and USB5 (the two USB "devices" that have enabled S-states). Still no joy.

Here are the contents of /proc/acpi/wakeup:

Device  S-state   Status   Sysfs node
SBAZ      S4    *disabled  pci:0000:00:14.2
PS2K      S3    *disabled
PS2M      S3    *disabled
UAR1      S4    *disabled  pnp:00:06
P0PC      S4    *disabled  pci:0000:00:14.4
UHC1      S4    *enabled   pci:0000:00:12.0
UHC2      S4    *enabled   pci:0000:00:12.2
UHC4      S4    *enabled   pci:0000:00:13.2
UHC6      S4    *enabled   pci:0000:00:16.2
UHC7      S4    *enabled   pci:0000:00:14.5
PC02      S4    *disabled  pci:0000:00:02.0
PC03      S4    *disabled
PC04      S4    *disabled  pci:0000:00:04.0
PC05      S4    *disabled  pci:0000:00:05.0
PC06      S4    *disabled
PC07      S4    *disabled
PC09      S4    *disabled  pci:0000:00:09.0
PC0A      S4    *disabled  pci:0000:00:0a.0
PC0B      S4    *disabled  pci:0000:00:0b.0
PC0C      S4    *disabled
PC0D      S4    *disabled  pci:0000:00:0d.0
PE20      S4    *disabled  pci:0000:00:15.0
PE21      S4    *disabled  pci:0000:00:15.1
PE22      S4    *disabled  pci:0000:00:15.2
PE23      S4    *disabled  pci:0000:00:15.3
USB3      S4    *enabled   pci:0000:00:13.0
USB5      S4    *enabled   pci:0000:00:16.0
PWRB      S4    *enabled   platform:PNP0C0C:00

Why aren't the controllers registering as HID-compliant devices?

1

I would try Caffeine. Go to a terminal by pressing Ctrl+Alt+T and copy-paste:

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine

and then add caffeine-indicator to your startup applications.

  • I followed your instructions and the Caffeine indicator is present when I boot, but I don't have any way of toggling it on/off with my gamepad. Also, this solution is the same as temporarily disabling power management. It would be nice if it worked passively like on my Mac. – guttermonk Aug 7 '15 at 23:43
  • Just tried to add caffeine to my startup applications (instead of caffeine-indicator), which should prevent desktop idleness, without a UI, for full screen applications. Unfortunately, it didn't stop my system from suspending while playing Shadows of Mordor through Steam with a Steam Controller. – guttermonk Jan 2 '16 at 4:26
1

Good news. I just tried the Steam Controller, and it registers as a HID on Windows and Linux. I just tested this with my new steam controller, and it indeed will wake the computer from sleep. I put it to sleep through the Steam big picture interface, let the machine fully deactivate (fans and LEDs off), and then hit the Steam button on the controller. Everything came to life. Score another point for the steam controller over wireless xbox360 controllers.

::UPDATE:: This is only partially correct as it only keeps the system from suspending when the controller is being used as a keyboard or mouse. When the controller is mapped to a typical xbox controller's buttons, the system still keeps suspending.

enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.