1

I recently watched this video: https://www.youtube.com/watch?v=a5La0XhLIaY

And now every time I open my browser, it is one of my startup pages (although not replacing any of the existing), I have looked in my settings and it is not marked as a startup page. I have also been experiencing other similar issues, such as when I have multiple tabs open and I click the close button, and I don't get it asking me if I want to close all the tabs, it just closes, and launches them all back up again as they were next time I open my browser, I even have a problem where sometimes I go to a site, it is the only tab, I close my browser, the next day when I boot my machine up, and start my browser, it goes to where I left off when I last closed my browser instead of opening my startup pages. These issues come and go though and are likely to just be bugs, however almost every time I start up my browser, it starts the video I stated above, and although it is nice at first, that video really does get a little annoying...

So really that is my question, how can I get Firefox to startup and not have that video as an additional startup page? And why I am I experiencing these very similar issues any way? Bug? Or something else?

If it helps, I am on Ubuntu Gnome 15.04, with Gnome Shell, and Gnome 3.14.

Firefox Plugins and Extensions:

enter image description here

enter image description here

For those of you who do not want to go to the video at least until you have seen what awaits you there:

enter image description here enter image description here

Information Update:

I have tried purging and reinstalling Firefox as well as deleting everything in ~/.mozilla/firefox.


OS Information:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid

Package Information:

firefox:
  Installed: 39.0+build5-0ubuntu0.15.04.1
  Candidate: 39.0+build5-0ubuntu0.15.04.1
  Version table:
 *** 39.0+build5-0ubuntu0.15.04.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ vivid-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ vivid-security/main amd64 Packages
        100 /var/lib/dpkg/status
     37.0+build2-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
17
  • Is it a pinned tab? Jul 31, 2015 at 18:50
  • @NathanOsman: Nope.
    – user364819
    Jul 31, 2015 at 18:52
  • Which extensions, plugins, etc. do you have installed? Can you provide screenshots of the startup window, and your preferences related to startup?
    – muru
    Jul 31, 2015 at 19:00
  • What a pain. Does it come back it you use a new profile firefox -P if not, and you can not find the cause, you may need to save / export your bookmarks and PW and use a new profile. You could also try adblock such as noscript or some such
    – Panther
    Jul 31, 2015 at 19:00
  • @muru: Sorry, that would contain some private stuff so I can't do that. But I can tell you which plugins I have.
    – user364819
    Jul 31, 2015 at 19:02

1 Answer 1

0

Sounds like a session problem. Firefox can restore sessions with each start. So you might want to try this. You don't say which version it is so I'll give an answer how it can be solved in the version I use.

Go to: Options > General > When Firefox starts > change the option from “Show my windows and tabs from last time”. Now restart and the annoying tab should be gone All other tabs are gone too so make bookmarks if you want fo keep (some of) them.

3
  • I do give the version in the Package Information section.
    – user364819
    Aug 1, 2015 at 13:35
  • Also, that settings area does not exist in my version, plus, the place where a similar option to that exists, does not have that option turned on, so this is definitely not the problem, as the option is set not to start the previous tabs and windows, but instead the startup pages which I defined. The only time when it should be behaving as it is is when it detects that the last session closed because of a crash, but it did not, so something is either crashing, or being misinformed, or something else is going wrong.
    – user364819
    Aug 1, 2015 at 14:54
  • Sorry, So you have version 39.0. Session problems might still be the source of the problem. There are a few possible causes possible. Can you please check if Firefox really shutsdown if it is supposed to shutdown (so it should not crash). If yes: can you check if there's a file called user.js in the firefox profile folder. If yes:move it and check if the problem is solved.If no: can you check if there's a file called lock in the profile folder. If yes: delete it and recheck the problem.
    – wie5Ooma
    Aug 1, 2015 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy