4

I dual-booted Ubuntu 15.04 alongside Windows 10. There is a known issue with the audio in linux on this computer: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1441852

The older models that came with windows 8 apparently had a fix: http://h30434.www3.hp.com/t5/Notebook-PC-Sound-and-Audio/HP-spectre-x360-on-linux/td-p/4980797

In summary, the fix was to edit /etc/default/grub and change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'" to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'", run update-grub, and reboot twice. You then may/may not have to click audio icon, go to sound settings, and then double click audio device.

I followed these steps, and they do work. The problem is...after I boot into 'Windows Boot Manager' (the only option to boot into windows 10 on grub), and then shut down or restart and boot into ubuntu, the sound device goes away. Running update-grub and rebooting into ubuntu again will make the audio device return in the audio settings. The changes to /etc/default/grub persist between all reboots.

Any ideas/advice/insight on how to ensure audio device remains present after booting in ubuntu after booting into windows 10?

  • The fix and the issue are the same with older models (mine 4002-dx) too. Have to boot+reboot ubuntu after booting into windows for sound to work. – Yalok Iy Sep 13 '15 at 9:05
-3

i just recently ran into troubles using kali on the x360 4005 ubuntu ran fine with just secure boot off but for kali i had to make sure it was in legacy mode and i had to choose the EFI boot after that from the USB the ubuntu dvd worked fine but kali gave a nothing but black on the dvd i had to use a usb stick for that after you enable secure boot off you have to enable legacy mode on but your grub should have been loaded off the ubuntu media and should say ubuntu at the end of it...and that should always have the ubuntu selection and windows boot in the grub selection...i would say make sure your ubuntu grub install is in your media and its up to date which on 15 it should be...if you see the splash menu on startup with media in it should be the same splash with the media out once you install..otherwise you might have a broken install maybe recompile the media and retry...

  • 5
    Welcome to Ask Ubuntu! ;-) Could you please review the editing help to improve the readability of your questions in the future... ;-) Also, visiting the Ask Ubuntu Tour to better understand how this site works, would help as well! – Fabby Aug 18 '15 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.