1

I just got a new machine with dual boot Ubuntu+Windows 8.1 and set up a localhost using XAMPP in a way that allows me to edit and preview the files on both OSes (so htdocs and mysql databases have to be shared).

So, in Windows, no problem: XAMPP installed, moved htdocs and mysql folders to new location quite easily (by changing some configuration files), all tested and it works, great!

For Ubuntu I used LAMP and successfully changed the datadir BUT the wordpress database created in Windows could not be read due to an InnoDB error so I decided to install XAMPP (LAMP was completely removed via console following instructions, nothing remains).

I changed the htdocs location for XAMPP on Ubuntu the same way I did in Windows, using the httpd.conf file and changing "DocumentRoot" and "Directory". This is tested so I know it works. MySQL also works if I use the default directory for its databases, this was also tested.

I tried adding the "datadir" location in the my.cnf file for MySQL BUT at that point the MySQL in XAMPP does not start (gives "Starting" for a few seconds then Stops - red light). This problem can apparently be solved by changing usr.sbin.mysqld in apparmor (which I did when I tried to use LAMP) except that I cannot find usr.sbin.mysqld in /etc/apparmor.d

So, given that usr.sbin.mysqld exists only in the cache folder of apparmor.d and that said file can't be read by gedit (gives only red squares and gibberish in UTF-8), how can I solve this problem?

  • 1
    It is indeed too long to read..please ask a concise question. – Ron Aug 1 '15 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.