4

The ubuntu docs tell me that I can upgrade my desktop to 14.04.2 by running:

sudo apt-get install --install-recommends \
linux-generic-lts-vivid \
xserver-xorg-core-lts-vivid \
xserver-xorg-lts-vivid \
xserver-xorg-video-all-lts-vivid \
xserver-xorg-input-all-lts-vivid \
libwayland-egl1-mesa-lts-vivid

However, when I do, I run into package issues:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 empathy : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
           Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libcheese-gtk23 : Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
              Depends: gstreamer1.0-clutter but it is not going to be installed
 libclutter-1.0-0 : Depends: libcogl-pango15 (>= 1.15.8) but it is not going to be installed
                    Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libclutter-gtk-1.0-0 : Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libwayland-egl1-mesa-lts-vivid : Depends: libegl1-mesa-lts-vivid (= 10.5.2-0ubuntu1~trusty1) but it is not going to be installed
                                  Conflicts: xorg-renamed-package-lts-utopic
 xserver-xorg-core-lts-vivid : Depends: libgbm1-lts-vivid (>= 8.1~0) but it is not going to be installed
                               Recommends: libgl1-mesa-dri-lts-vivid (>= 7.10.2-4) but it is not going to be installed
                               Conflicts: xorg-renamed-package-lts-utopic
 xserver-xorg-input-all-lts-vivid : Depends: xserver-xorg-input-evdev-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-input-vmmouse-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-input-synaptics-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-input-wacom-lts-vivid but it is not going to be installed
 xserver-xorg-lts-vivid : Depends: xserver-xorg-input-evdev-lts-vivid but it is not going to be installed
                          Recommends: libgl1-mesa-dri-lts-vivid but it is not going to be installed
                          Recommends: libgl1-mesa-glx-lts-vivid but it is not going to be installed
                          Recommends: libegl1-mesa-lts-vivid but it is not going to be installed
                          Recommends: libegl1-mesa-drivers-lts-vivid but it is not installable
                          Recommends: libgbm1-lts-vivid but it is not going to be installed
                          Recommends: libgles2-mesa-lts-vivid but it is not going to be installed
                          Recommends: libgles1-mesa-lts-vivid but it is not going to be installed
                          Conflicts: libegl1-mesa (>= 0~)
                          Conflicts: libgl1-mesa-dri (>= 0~)
                          Conflicts: libgl1-mesa-dri:i386 (>= 0~)
                          Conflicts: libgl1-mesa-glx (>= 0~)
                          Conflicts: libgl1-mesa-glx:i386 (>= 0~)
                          Conflicts: libglapi-mesa (>= 0~)
                          Conflicts: libglapi-mesa:i386 (>= 0~)
                          Conflicts: libgles1-mesa (>= 0~)
                          Conflicts: libgles2-mesa (>= 0~)
                          Conflicts: xorg-renamed-package-lts-utopic
 xserver-xorg-video-all-lts-vivid : Depends: xserver-xorg-video-ati-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-cirrus-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-fbdev-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-intel-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-mga-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-neomagic-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-nouveau-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-openchrome-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-savage-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-siliconmotion-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-sisusb-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-tdfx-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-trident-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-vesa-lts-vivid but it is not going to be installed
                                    Depends: xserver-xorg-video-vmware-lts-vivid but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I was able to run the command to just install the kernel, but is there a solution for upgrading the xserver/mesa packages?

5

The correct command is

sudo apt-get install linux-generic-lts-vivid xserver-xorg-lts-vivid libqt5gui5 \
    libgles1-mesa-lts-vivid libgles2-mesa-lts-vivid libgl1-mesa-glx-lts-vivid \
    libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid:i386
| improve this answer | |
  • After doing that, every time I tried to log in, I would be kicked back out to the login screen, but I managed to startup in 3.16 again from the boot menu. Do I need to disable my nvidia proprietary driver and go back to the xorg one on my 3.16 kernel before rebooting? – Programster Jul 31 '15 at 10:20
  • You probably need to re-install nvidia driver. What is the driver? How did you install it? You can probably install nvidia 346 or 352 from xorg-edgers. – Pilot6 Jul 31 '15 at 10:23
  • I used the "additional drivers" program from the desktop dash. It's currently on 331.113. nvidia-331-updates. Once I boot into 3.19 cli what command do I need to run to reinstall the appropriate nvidia driver? – Programster Jul 31 '15 at 10:32
  • 331 may not build for 3.19. You'd better ask a separate question for that. – Pilot6 Jul 31 '15 at 10:34
  • 1
    It is included not to break dependencies. It is long to explain, but in some cases without it some packages can be removed. – Pilot6 Jul 9 '16 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.