I recently upgraded from 14.04 through to 15.04 so I could start working on a scope idea that I had. Prior to upgrading, I had installed the Ubuntu SDK and had it installed and partially working - but I was having issues with emulators and compiling.

It was suggested to me that I should upgrade to 15.04, and I had already been planning to do so, so I upgraded through 14.10 to 15.04.

However, along the way, the SDK was removed. I figured this was just a normal part of the upgrade process, I can just reinstall it when I get to 15.04.


When I run the sudo apt-get install ubuntu-sdk command, I get this output:

$ sudo apt-get install ubuntu-sdk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-sdk : Depends: ubuntu-sdk-libs-dev but it is not going to be installed
              Depends: phablet-tools but it is not going to be installed
              Depends: qtcreator but it is not going to be installed
              Depends: qtcreator-plugin-ubuntu but it is not going to be installed
              Depends: ubuntu-device-flash but it is not going to be installed
              Depends: ubuntu-ui-toolkit-autopilot but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have tried adding the ubuntu-sdk-team PPA via sudo add-apt-repository ppa:ubuntu-sdk-team/ppa, but that gives me the same error.

Output of apt-cache policy ubuntu-sdk:

$ apt-cache policy ubuntu-sdk
  Installed: (none)
  Candidate: 1.221
  Version table:
     1.221 0
        500 http://mirrors.gigenet.com/ubuntuarchive/ vivid/universe amd64 Packages

and apt-cache policy qtcreator:

$ apt-cache policy qtcreator
  Installed: 3.1.1-0ubuntu9
  Candidate: 3.1.1-0ubuntu9
  Version table:
 *** 3.1.1-0ubuntu9 0
        500 http://mirrors.gigenet.com/ubuntuarchive/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status

What can I do to fix this?


Output from apt-cache policy ubuntu-sdk-libs-dev:

  Installed: 1.221
  Candidate: 1.221
  Version table:
 *** 1.221 0
        500 http://mirrors.gigenet.com/ubuntuarchive/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status


Output from sudo aptitude install ubuntu-sdk:

$ sudo aptitude install ubuntu-sdk
The following NEW packages will be installed:
  account-plugin-tools{a} accountsservice-ubuntu-schemas{a} click-dev{ab} 
  click-doc{a} gdb-multiarch{a} libandroid-properties1{a} 
  libcontent-hub-doc{a} libhardware2{a} libhybris-common1{a} libpay2{a} 
  libqmenumodel0{a} libqt5bluetooth5{a} libqt5bluetooth5-bin{a} 
  libqt5declarative5{a} libqt5nfc5{a} libtrust-store1{a} 
  libu1db-qt5-examples{a} libubuntu-location-service2{a} 
  libubuntu-platform-hardware-api2{a} libubuntuoneauth-2.0-0{a} 
  libusermetricsoutput1{a} pay-service{a} phablet-tools{a} python-mock{a} 
  qml-module-qtqml-models2{a} qml-module-qttest{a} qt3d5-examples{a} 
  qtbase5-doc{a} qtbase5-examples{a} qtconnectivity5-examples{a} 
  qtcreator{a} qtcreator-plugin-cmake{a} qtcreator-plugin-go{a} 
  qtcreator-plugin-qnx{a} qtcreator-plugin-remotelinux{a} 
  qtcreator-plugin-ubuntu{a} qtcreator-plugin-ubuntu-common{a} 
  qtcreator-plugin-valgrind{a} qtdeclarative5-examples{a} 
  qtdeclarative5-unity-notifications-plugin{a} qtgraphicaleffects5-doc{a} 
  qtlocation5-examples{a} qtmultimedia5-doc{a} qtmultimedia5-examples{a} 
  qtquick1-5-examples{a} qtscript5-doc{a} qtscript5-examples{a} 
  qtsensors5-examples{a} qtsvg5-doc{a} qtsvg5-examples{a} 
  qtsystems5-examples{a} qttools5-doc{a} qttools5-examples{a} 
  qtxmlpatterns5-examples{a} thumbnailer-common{a} thumbnailer-service{a} 
  ubuntu-emulator{a} ubuntu-emulator-runtime:i386{a} ubuntu-sdk 
  ubuntu-sdk-libs-dev ubuntu-ui-toolkit-autopilot{a} 
  ubuntu-ui-toolkit-examples{a} ubuntuone-credentials-common{a} 
  unity-plugin-scopes{a} unity-scope-tool{a} unity8-common{a} 
  unity8-fake-env{a} unity8-private{a} 
The following packages will be REMOVED:
  libprocess-cpp-doc{u} libproperties-cpp-doc{u} 
0 packages upgraded, 70 newly installed, 2 to remove and 0 not upgraded.
Need to get 105 MB/119 MB of archives. After unpacking 287 MB will be used.
The following packages have unmet dependencies:
 click-dev : Depends: python3-click (= but is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:              
1)     click-dev [Not Installed]                                        
2)     qtcreator-plugin-ubuntu [Not Installed]                          
3)     ubuntu-sdk [Not Installed]                                       

     Leave the following dependencies unresolved:                       
4)     libproperties-cpp-dev recommends libproperties-cpp-doc           
5)     libprocess-cpp-dev recommends libprocess-cpp-doc                 
6)     qtcreator-plugin-ubuntu-common recommends qtcreator-plugin-ubuntu

Accept this solution? [Y/n/q/?] 

EDIT 3: Output from apt-cache policy python3-click:

$ apt-cache policy python3-click
  Version table:
 *** 0
        100 /var/lib/dpkg/status 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
  • I've had bad luck with the PPA, and I generally always advise to do fresh installs when updating between minor releases. However, I have had good luck compiling qtcreator from source, which will at least get you the fundamentals. – Akiva Jul 31 '15 at 4:51
  • What about apt-cache policy ubuntu-sdk-libs-dev? Also, the output for your second command is from the first command. – saiarcot895 Aug 2 '15 at 15:11
  • @saiarcot895 You're right! O.O Oops. Just updated the question and added the new stuff/updated mistake. – RPiAwesomeness Aug 2 '15 at 16:30
  • @RPiAwesomeness: Hmm...I didn't expect that. Are you still getting the error. What if you install aptitude and try sudo aptitude install ubuntu-sdk? (I find Aptitude's error handling is much better than apt-get's) – saiarcot895 Aug 2 '15 at 16:31
  • @saiarcot895 Edited my question – RPiAwesomeness Aug 2 '15 at 20:14

The reason ubuntu-sdk can't be installed is because there is a higher version of the python3-click package already installed than the one required by some dependency, and this version is not from the main repos.

You'll need to downgrade the version of python3-click installed. You can do this by either running sudo aptitude install python3-click= or going through the list of resolutions given by sudo aptitude install ubuntu-sdk and selecting the one that downgrades the package.


After your last edit, the package python3-click blocks the installation of ubuntu-sdk. Therefore remove the (manually via deb-file?) installed version and install the version from the Ubuntu repositories.

sudo aptitude reinstall python3-click
sudo aptitude install ubuntu-sdk

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.