2

I have xubuntu on an Acer c720. This means that there is no delete key on the keyboard. After googling for a while i find that everyone has solved this by adding

"xdotool keyup shift+BackSpace; xdotool key Delete; xdotool keydown shift" 
shift+BackSpace

to the xbindkeysrc file and then $ xbindkeys &. For some reason, when i then press shift+BackSpace, it's like the shift key is constantly pressed in(i.e. All Caps, left and right buttons while in text marks the text, when clicking on the desktop the roll down box appears).

Since the shift key is allways pressed in it's kind of hard to test, but i think the BackSpace key also permanently functions as the Delete key, but i might be wrong about that.

Why is this happening? Why doesn't anyone else seem to have this problem? How do i fix this so that shift+BackSpace acts like a delete key?

Any help would be appreciated, Thanks!

  • Install sudo apt-get install xautomation and try this two lines: 1) "xte 'key Delete'" and 2) Shift+Mod2 + BackSpace and give me a ping with @A.B. – A.B. Jul 31 '15 at 6:31
  • @A.B. I tried that(but i used mod4 since i didn't find mod2) and nothing happened when i pressed the buttons, do i have to install xte?(is this pinging? I'm new at this site) – Martin Brischetto Jul 31 '15 at 6:50
2

I found a solution to my problem. I use the commands:

sudo apt-get install xvkbd           #to install the package
xvkbd -xsendevent -text '\[Delete]'  #to activate the correct key

instead, it works great. I still don't know why the other method doesn't work for me.

| improve this answer | |
  • You should mention that the package xvkbd is not installed by default. – A.B. Jul 31 '15 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.