On the virtual machine when I update grub (sudo update-grub) and restart I get the BusyBox initramfs shell on boot.

I have a checkpoint on the machine so I can easily go back to just before I ran the command and reboot to regain access to the fully booted machine.

Ordinarily I wouldn't really care because I could just not update grub. However, I want to increase the resolution on the machine and this requires running that command and rebooting. Which as stated, kills the installation.

The os is Ubuntu 15.04, 64 bit.

This is the output when I run the command. I don't know if there's anything weird going on there? enter image description here

This is what happens when I reboot and this is all, there's no other information, unlike most of the screenshots of initramfs I've seen online. enter image description here

How do I fix this? Bear in mind that I have access to the fully booted desktop pre initramfs error and pre grub update.

Thank you in advanced!

EDIT: I thought I should add that I have Ubuntu installed on a virtual hard drive. I am then accessing and making changes through a differencing disk.

EDIT: I've managed to work around the initramfs error and get my full screen resolution.

I added the video=hyperv_fb:1920x1080 line to the etc/default/grub file as the resolution tutorial told me to and ran the update-grub command.

I then saved the /boot/grub/grub.cfg file and reverted back to the old checkpoint. I then compared the 'old' cfg file which was now back in place with the edited one. I found all the places that my video line should be and re-added them back in.

I then rebooted and hooray it worked. I still cannot run update-grub, but I have managed to get my full screen resolution by doing this :)

  • 1
    I have the same problem. I created a new Xubuntu 15.04 VM in Hyper V. The VM runs fine till you update the system updates. After you do so, the OS will give a kernel panic and then drop you into an initramfs prompt on subsequent reboots.
    – abjbhat
    Aug 1, 2015 at 7:16

1 Answer 1


you need to use this:

 sudo -i
 fsck.ex4 -b 8079
 efibootmgr /boot/initrd.img-3.19.0-15-generic

and it might work fine this way.

  • I assume you mean fsck.ext4? And this command doesn't seem to work. I've tried adding /dev/sda1 which is the drive partition but it complains that this is mounted. The final command (efibootmgr...) says that 'EFI variables are not supported on this system.'
    – DanMc
    Aug 3, 2015 at 14:43
  • @DanMc This is just crap as an answer. The last command makes no sense at all.
    – Pilot6
    Aug 8, 2015 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .