2

When I'm scrolling around code, I sometimes put my mouse over the horizontal scrollbar and then the mouse wheel scrolls horizontally which is not what I'm used to.

More annoyingly, the two-finger scroll which allows me to scroll vertically or horizontally by moving my fingers up-and-down or left-and-right also changes to scrolling horizontally when going up-and-down if my mouse happens to be over a horizontal scrollbar.

The first problem is my preference but I think the second problem is a bug. How do I change these behaviours?

I'm using Ubuntu 15.04 Vivid with the default window manager, Unity.

0

May be, using 'xinput' and disable that action buttons.

xinput list -> list devices ID
xinput test <ID> -> monitor actions
If you see, that scroll action use mouse buttons 6 and 7. Disable that buttons.

xinput set-button-map <ID> 1 2 3 4 5 0 0

Better solution will be, disable that that scroll action in GUI system, but I don't know that solution. Probably it depend also on specific window manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.