2

I am working on a brand new laptop with xubuntu 15.04. Wireless is working ok. Wired connection says connected when plugged in, and disconnected after 2 seconds or so. "Enable networking" is ticked. The ethernet cable from switch is working perfectly well on my other xubuntu machine. How can I get a wired connection?

henk@henk-W330AU:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid
henk@henk-W330AU:~$ sudo lshw -c Network
  *-network               
       description: Wireless interface
       product: Wireless 7265
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 48
       serial: 60:57:18:da:6c:54
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.19.0-25-generic firmware=25.17.12.0 ip=192.168.1.74 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:51 memory:f7100000-f7101fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:03:00.1
       logical name: eth0
       version: 12
       serial: 80:fa:5b:16:62:dd
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8411-2_0.0.1 07/08/13 ip=192.168.1.82 latency=0 link=yes multicast=yes port=MII speed=10Mbit/s
       resources: irq:49 ioport:e000(size=256) memory:f7014000-f7014fff memory:f7010000-f7013fff
2
  • Do you disable wireless connection when you try the wired? – Pilot6 Jul 30 '15 at 7:51
  • Yes, I have tried disabling it, that gives the message connected to wired network followed immediately by disconnected from wired network – Henk Jul 30 '15 at 7:54
3

You can try to install another driver for this Ethernet card

sudo apt-get install r8168-dkms

If that does not help, check the cable, contacts on both sides.

Expanaition

Realtek Ethernet RTL8111/8168 adapters are generally supported out of the box by Linux kernel. There is r8169 module for that. In most cases it works well.

But some hardware revisions of these adapters may not be well supported yet. It may result in packet loss ar inability to connect, like in this case. It should be reported as a bug to kernel maintainers.

As a workaround a driver developed and maintained by Realtek engineers can be used. It is available in Ubuntu repositories as r8168-dkms.

This package blacklists r8169 and installs r8168 instead. If it is removed, r8169 is restored.

5
  • success! the problem was the driver. – Henk Jul 30 '15 at 8:30
  • Do you know all the drivers in person? ;) – A.B. Jul 30 '15 at 8:39
  • @A.B. I do a lot of installs ;-) – Pilot6 Jul 30 '15 at 8:41
  • @Pilot6 When I tried this on Ubuntu 14.04.4 LTS I got Building initial module for 3.19.0-59-generic Error! Bad return status for module build on kernel: 3.19.0-59-generic (x86_64) Consult /var/lib/dkms/r8168/8.037.00/build/make.log for more information. – Steve Roome May 23 '16 at 11:35
  • You probably need to download a newer package from the repos for this kernel. – Pilot6 May 23 '16 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.