1

This question already has an answer here:

I am trying to install Yeoman in my machine but i am getting the error node outdated,when i checked my versions i got this.

 node --version && npm --version 
v0.10.37
1.4.28

if my versions are ok then why i am getting these error.Whats the cause for this.

    Running sanity checks on your system

✔ No .bowerrc file in home directory
✔ Global configuration file is valid
✔ NODE_PATH matches the npm root
✖ Node.js version

List item

Your Node.js version is outdated.
Upgrade to the latest version: https://nodejs.org

✔ No .yo-rc.json file in home directory
✖ npm version

Your npm version is outdated.

Upgrade to the latest version by running:
npm install -g npm


Found potential issues on your machine :(
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/npm-package-arg requires semver@'4' but will load
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/semver,
npm WARN unmet dependency which is version 2.3.0
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/rimraf/node_modules/glob requires inflight@'^1.0.4' but will load
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/inflight,
npm WARN unmet dependency which is version 1.0.1
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/rimraf/node_modules/glob requires minimatch@'^2.0.1' but will load
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/minimatch,
npm WARN unmet dependency which is version 1.0.0
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/node-gyp/node_modules/glob requires inflight@'^1.0.4' but will load
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/inflight,
npm WARN unmet dependency which is version 1.0.1

marked as duplicate by A.B., Community Jul 30 '15 at 8:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.