7

UPDATING:

I followed every step of this guide but still getting the black screen with the system alive and can't go to tty1-6. So now I'm on Ubuntu 15.04 (kernel: 4.1.3-040103-generic). I found this messages from dmesg but i don't think that are related to my main problem:

  1. Error parsing PCC subspaces from PCCT
  2. psmouse serio1: synaptics: Unable to initialize device.
  3. i2c_hid i2c-DLL0665:01: failed to retrieve report from device.

Any help please?

First Post:

I bought a Dell XPS 13 (2015 - 9343)/QHD+/8GB/256SSD with Windows 8, updated BIOS to A04 and then installed Ubuntu 14.04 (kernel: 3.16). The problem is I'm getting a black screen sometimes after booting, after login and when returning from suspend. I can go to tty1-6 and then CTRL+ALT+F7 that sometimes return to normal but normally it needs a reboot.

I also already tried installing Ubuntu 15.04 (kernel: 3.19) and elementary OS Freya (kernel: 3.16) but always getting the same problem.

$ lshw -c video

 *-display               
      description: VGA compatible controller
      product: Broadwell-U Integrated Graphics
      vendor: Intel Corporation
      physical id: 2
      bus info: pci@0000:00:02.0
      version: 09
      width: 64 bits
      clock: 33MHz
      capabilities: vga_controller bus_master cap_list rom
      configuration: driver=i915 latency=0
      resources: irq:48 memory:f6000000-f6ffffff memory:e0000000-> efffffff ioport:f000(size=64)

I added xorg-edge ppa and upgraded but it didn't solve the problem either. I also installed this packages (http://www.dell.com/support/article/uk/en/ukdhs1/SLN297551/en?c=uk&s=gen&cs=&l=en) but still with the problem.

$ lshw -c network

  *-network               
      description: Wireless interface
     product: BCM4352 802.11ac Wireless Network Adapter
    vendor: Broadcom Corporation
      physical id: 0
      bus info: pci@0000:02:00.0
      logical name: wlan0
      version: 03
      serial: ac:d1:b8:c1:0d:6b
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
      configuration: broadcast=yes driver=wl0 driverversion=6.30.223.248 (r487574) ip=192.168.1.38 latency=0 multicast=yes wireless=IEEE 802.11abg
      resources: irq:19 memory:f7200000-f7207fff memory:f7000000-f71fffff 
1
  • 1
    What wireless card do you have ? A Broadcom or an Intel ? – hg8 Jul 30 '15 at 7:17
2

I have the exact same issue, right now the workaround is to suspend/resume or blindly open terminal through Ctrl+Alt+T and type xset dpms force off then just move the mouse and screen should be back.

I still haven't been able to find a real solution.

3
  • have you tried putting that command in the sleep/resume script? – Fabby Sep 4 '15 at 20:03
  • I have actually put a custom script and associated that to ctrl+super+s to restart the screen. 'xset dpms force off; sleep 1; xset dpms force on' – Omer Akram Sep 6 '15 at 14:37
  • thanks man.. the problem persists but this workaround really did the trick! – rafaelcsales Sep 19 '15 at 5:14
-1

take a look here, quite good feedback for XPS13 setup. I'm running A03 + Ubuntu 15.04 Linux 3.19.0-25-generic #26-Ubuntu https://major.io/2015/02/03/linux-support-dell-xps-13-9343-2015-model/

1
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – hg8 Aug 26 '15 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.