3

I am running Ubuntu 14.04 from Windows, using virtualbox 5.0. I tried several options to make size of Ubuntu in virtual box larger, but none helped so far.

  • I am using latest virtual box with latest guest add on installed.

  • sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11

  • I went to Ubuntu 'software and Updates' and made sure that under 'Additional Drivers' tab, 'using x86 visualization solution...' is active.

  • In virtualbox window, under view->virtual screen 1, all 'resize to' options are disabled.

None of these options helped. This is frustrating. Any comments or help? Can the problem be I am using 64 bit system? Does this problem occurs in earlier/later versions? If not, please suggest a 'good' version of Ubuntu for virtualbox.

6

This is caused by a lack of video memory. By default, Virtualbox only allocates 12MB to an Ubuntu VM, and as such, the size of the virtual machine is small:

enter image description here

The way to fix this is fairly straightforward.

Once you create the VM and install Ubuntu, restart. Once you do that, go ahead and press the Ctrl+D. Make sure to press the right Ctrl, not the left.

Alternatively, you can go up to the top of the VM window and click Devices > Insert Guest Additions CD Image:

enter image description here

A window may pop up saying "VBOXADDITIONS_VERSIONUMBERS" contains software intended to be automatically started. Would you like to run it?. You can click yes, this will just skip the next two steps.

If the window I just mentioned doesn't automatically pop up, go ahead and click on the CD icon in the Unity taskbar:

enter image description here

Go ahead and close the Nautilus window that opens up, and press Ctrl+Alt+T.

This will open a Terminal window, in which you should enter cd /media/YOURUSERNAME/VBOXADDITIONS and then hit Tab, then Enter:

enter image description here

Then, go ahead and type sudo chmod +x VboxLinuxAdditions.run && sudo ./VboxLinuxAdditions.run.

You may be prompted for your password, go ahead and put it in.

Once you do so, the installer will run. Once it completes:

enter image description here

you'll need to restart. Close the Terminal window and restart the VM, and you're almost done!

Once the VM shuts down, right-click on the VM in the main VirtualBox window and select the Settings item:

enter image description here

Once the window opens, go ahead and select the Display tab along the left.

Then, drag the Video Memory option all the way to the right. What previously said 12 MB should now say 128 MB.

enter image description here

Go ahead and start up the VM, and you should be able to go full screen, as well as any other size you want!

  • Thanks a ton for this answer! Worked successfully! I saw many other blogs, posts, webpages, and tried many different things. But this method worked. Thanks again! By the way, in your last picture, virtualbox Ubuntu settings -> display -> video -> 'Extended Features' -> Enable 2D, 3D acceleration. What these options are? Are they connected with graphics performance? – 343_458 Jul 30 '15 at 22:22
  • @343_458 Glad I was able to help! As for the options, they simply allow VirtualBox to have direct access to the GPU's 3D and 2D rendering capabilities, instead of via software. It's a personal choice, I've never noticed any difference in performance/load on your physical system with it on or off. Granted, I've never done anything super insane with a VM, I've just used them to test various things. Welcome to Ask Ubuntu! – RPiAwesomeness Jul 31 '15 at 0:35
  • I've found some apps fail with 3D enabled. – Tony O'Hagan Oct 16 '17 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.