2

This appears to be an issue for many. None of the suggested soloutions have worked for me:

cant-login-to-ubuntu-14-04-after-upgrade

  • The permissions and state of .Xauthority & .ICEauthority are fine. Home dir is good, /tmp is as it should be.

unity-doesnt-load-no-launcher-no-dash-appears

  • Setting the Ubuntu Unity plugin in ccsm did not have any effect.

I am running a provisioned VM from Oracle VBox.

It appears that the XServer isn't loading opengl:

glxinfo
name of display: :0.0
Segmentation fault (core dumped)

The syslog is throwing errors but, not sure why glx is not found:

Jul 29 13:13:21 <user> systemd[1]: Started Session c31 of user <user>.
Jul 29 13:13:21 <user> systemd[1]: Starting Session c31 of user <user>.
Jul 29 13:13:22 <user> org.a11y.Bus[15795]: Activating service name='org.a11y.atspi.Registry'
Jul 29 13:13:22 <user> org.a11y.Bus[15795]: Successfully activated service 'org.a11y.atspi.Registry'
Jul 29 13:13:22 <user> org.a11y.atspi.Registry[15843]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Jul 29 13:13:22 <user> gnome-session[15915]: Xlib:  extension "GLX" missing on display ":0".
Jul 29 13:13:22 <user> gnome-session[15915]: message repeated 2 times: [ Xlib:  extension "GLX" missing on display ":0".]
Jul 29 13:13:22 <user> gnome-session[15915]: gnome-session-is-accelerated: No hardware 3D support.
Jul 29 13:13:22 <user> gnome-session[15915]: Xlib:  extension "GLX" missing on display ":0".
Jul 29 13:13:22 <user> gnome-session[15915]: gnome-session-check-accelerated: Helper exited with code 256
Jul 29 13:13:22 <user> gnome-session[15915]: CRITICAL: We failed, but the fail whale is dead. Sorry....

Jul 29 13:13:22 <user> gnome-session[15915]: gnome-session[15915]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Jul 29 13:13:22 <user> org.gnome.ScreenSaver[15795]: ** (gnome-screensaver:16003): WARNING **: Unable to get session bus: Failed to connect to socket /tmp/dbus-iYL1eZW4MO: Connection refused

Jul 29 13:13:22 <user> org.gnome.ScreenSaver[15795]: ** (gnome-screensaver:16003): WARNING **: failed to register with the message bus

Jul 29 13:13:23 <user> lightdm[1271]: /etc/modprobe.d is not a file
Jul 29 13:13:23 <user> lightdm[1271]: message repeated 3 times: [ /etc/modprobe.d is not a file]
Jul 29 13:13:23 <user> lightdm[1271]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Jul 29 13:13:23 <user> systemd[1]: Started Session c32 of user lightdm.
Jul 29 13:13:23 <user> systemd[1]: Starting Session c32 of user lightdm.
Jul 29 13:13:23 <user> org.a11y.atspi.Registry[16137]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry

All this is telling me is that the whale is dead.

lcpci is finding my graphics card:

00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

Additionally, setting the display manager to gdm bricks it.

I can get in to the machine by logging in to GNOME Classic (MetaCity) but no other desktop will work. Except KDE.

1

All I had to do was post a question here. Some combination of the above worked finally. The last thing I did was:

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop

and then

dconf reset -f /org/compiz/
setsid unity

from Unity missing? Can't see top or side panels

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.